[OEL8.2] Resource Limits changes not registering on Dell Optiplex 3060 micro — oracle-tech

    Forum Stats

  • 3,708,780 Users
  • 2,241,126 Discussions
  • 7,840,613 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

[OEL8.2] Resource Limits changes not registering on Dell Optiplex 3060 micro

ASGR71ASGR71 Posts: 44 Red Ribbon
edited July 2020 in Oracle Linux

Hi All,

I have a Dell Optiplex 3060 Micro that is/was a supported machine for the database platform

as per Red-Hat website.

Since Oralce Enterprise Linux 7.6, the Resource Limits will not accept changes through

any technique making any attempt to install the database futile and having to resort to

OEL 7.5 but without ANY upgrades.

And yes, OEL 7.5 works flawlessly by either pasting the resource limits into /etc/security/limits.conf

or as a separate file in /etc/security/limits.d/50-oracle-limits.conf but not being able to

utilise any upgrade feature as it would install OEL 7.6 and the system would immediately

become unusable.

Has anybody experienced this or know of a solution? Next step is to post on Red Hat or Dell!

This issue has exhausted my interest levels and I'll be abandoning Oracle Linux in favour of

another strain of Fedora or Sun OS.

Regards,

A.

Tagged:

Best Answer

  • ASGR71ASGR71 Posts: 44 Red Ribbon
    Accepted Answer

    Just to conclude...


    Oracle Solaris was a nightmare to install and didn't work properly on third party hardware.

    Hello again Oracle Linux! Went through the entire limits and security setup documentation

    to make sure I didn't make any parameter errors but still can't set the Soft Stack value to

    10240 through the system config files.


    As suggested by several users, this seems to be the most effective solution...

    Put similar code like below in the user bash profile and all works well.

       if [ "$USER" = "oracle" ]; then

          if [ "$(ulimit -Ss)" != 10240 ]; then

             ulimit -s 10240

             fi

          fi


    Thanks for everyone help.

Answers

  • ASGR71ASGR71 Posts: 44 Red Ribbon
    edited June 2020

    Thanks Dude,

    I'll try a complete factory reset of the computer and eliminate any OS security setup during install and get back to you here.

  • ASGR71ASGR71 Posts: 44 Red Ribbon
    edited June 2020

    Thanks Dude!,

    I've also been investigating the resource limits aspect of this problem and it may be that since OEL-7.6 Red Hat may have excluded the following:

        session required pam_limits.so

    from the following file

        /etc/pam.d/login

    Still having some resource limit issues but it may be because I've not changed the sysctl variables...

    Apparently I should do this before limits.conf (head-smack emoji!).

  • ASGR71ASGR71 Posts: 44 Red Ribbon
    edited June 2020

    Thanks again Dude!,

    I have found something interesting in the following file /etc/pam.d/su:

    session include   postlogin

    session require   pam-limits.so

    session optional  pam_xauth.so

    the bold text has been completely mis-typed! It should read;

    session required pam_limits.so

    Can anyone confirm this on there installation?

  • ASGR71ASGR71 Posts: 44 Red Ribbon
    edited June 2020

    The plot thinkens!

    Looks like systemd also likes to set resource limits without any interaction through ulimit.

    You just have to look through /etc/systemd/system.conf to see the similarities.

    I'm under the impression that ulimit is a legacy method of setting resource limits and one

    day will be fully superceeded by systemd. It's the new golden standard!

    In conclusion, I'll have to agree with your solution with the addition to /etc/profile.

    I'm tempted to set all the limits through /etc/profile if you don't foresee any issues?

    I'd rather keep them all in one place instead of flipping between locations.

    Much Appreciated,

    A.

  • ASGR71ASGR71 Posts: 44 Red Ribbon
    edited July 2020

    Thanks for all your help dude!

    I've given up on Linux and only heard much better things about Solaris.

    I'm ONLY focusing on Solaris now!

  • ASGR71ASGR71 Posts: 44 Red Ribbon
    Accepted Answer

    Just to conclude...


    Oracle Solaris was a nightmare to install and didn't work properly on third party hardware.

    Hello again Oracle Linux! Went through the entire limits and security setup documentation

    to make sure I didn't make any parameter errors but still can't set the Soft Stack value to

    10240 through the system config files.


    As suggested by several users, this seems to be the most effective solution...

    Put similar code like below in the user bash profile and all works well.

       if [ "$USER" = "oracle" ]; then

          if [ "$(ulimit -Ss)" != 10240 ]; then

             ulimit -s 10240

             fi

          fi


    Thanks for everyone help.

Sign In or Register to comment.