Unable to install EMCC13.4 with 19c template database (19.5.0.0.0) — oracle-tech

    Forum Stats

  • 3,708,780 Users
  • 2,241,126 Discussions
  • 7,840,613 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Unable to install EMCC13.4 with 19c template database (19.5.0.0.0)

LauryLaury Posts: 1,618 Silver Badge
edited June 2020 in Enterprise Manager

Hi,

I am trying to install EMCC13.4 with a 19c EE database.

I have first installed RDBMS software 19.0.0.0, and patched it with patch 30125133 up to 19.5.

Then I created a database using SMALL template from 19.5.0.0_Database_Template_for_EM13_4_0_0_0_Linux_x64.zip.

Following the DBCA instructions, this is not a CDB database.

I end up with a database with this version:

SQL>

column banner_full format a75 

select banner_full from v$version;

---

BANNER_FULL

---------------------------------------------------------------------------

Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production

Version 19.5.0.0.0

---

The database created to be used as rcpository is created with:

SGA: 1200M

PGA: 1000M

Also before to start the Oracle documentation states:

"If the Management Repository is using Oracle Database 12.2, 18.x or 19.x,

there's no need to set any parameters since they will be addressed when

applying patch 30912308 during the installation process..."

and:

"Otherwise, if you plan not to follow any of the above recommended methods to apply patch 30912308

during the installation process then you must to connect to the database as SYSDBA and run the following..."

As I do not use this patch, this is what I have done:

alter system set "_optimizer_nlj_hj_adaptive_join"= FALSE scope=both sid='*';

alter system set "_optimizer_strans_adaptive_pruning" = FALSE scope=both sid='*';

alter system set "_px_adaptive_dist_method" = OFF scope=both sid='*';

alter system set "_sql_plan_directive_mgmt_control" = 0 scope=both sid='*';

alter system set "_optimizer_dsdir_usage_control" = 0 scope=both sid='*';

alter system set "_optimizer_use_feedback" = FALSE scope=both sid='*';

alter system set "_optimizer_gather_feedback" = FALSE scope=both sid='*';

alter system set "_optimizer_performance_feedback" = OFF scope=both sid='*';

Then I bounced the instance.

Then I started the installation of EMC1134 with the GUI as:

./em13400_linux64.bin

The installation failed during the "Configure" stage, and failed during "Repository Out of Box Configuration".

If I click "View log", the last lines are:

---

...

NFO: oracle.sysman.top.oms:The OutOfBox command execution completed with the status 255.

INFO: oracle.sysman.top.oms:File is moved successful!

INFO: oracle.sysman.top.oms:The plug-in Repository Out Of Box Configuration has failed its perform method

---

pastedImage_1.png

If I look at the last log in:

/u01/app/oracle/base/product/middelware/134/cfgtoollogs/cfgfw

I see:

---

...

INFO: oracle.sysman.top.oms:Enter password for: SYS

INFO: oracle.sysman.top.oms:^H ^HEnter password for: SYSMAN

INFO: oracle.sysman.top.oms:^H ^HError found: SQL exception - error has occured during the execution. The error trace message is

INFO: oracle.sysman.top.oms: java.sql.SQLException: ORA-01017: invalid username/password; logon denied

INFO: oracle.sysman.top.oms:

INFO: oracle.sysman.top.oms:The Connect Descriptor was (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=oel764-emcc13.localdomain)(PORT=1521)))(CONNECT_DATA=(SID=SOLARIS)))

INFO: oracle.sysman.top.oms:.

INFO: oracle.sysman.top.oms:The OutOfBox command execution completed with the status 255.

INFO: oracle.sysman.top.oms:File is moved successful!

INFO: oracle.sysman.top.oms:The plug-in Repository Out Of Box Configuration has failed its perform method

INFO: Cfm.save() was called

INFO: Cfm.save(): 5 aggregate instances saved

INFO: done waiting for Action from 19:01:18.279

---

When through SQL Plus I connect as SYS or SYSMAN with the password I provided in the GUI, I get connected without error.

Did someone face a similar situation?

Thanks by advance for any tip/indication.

Kind Regards.

Best Answer

  • LauryLaury Posts: 1,618 Silver Badge
    edited June 2020 Accepted Answer

    Hi,

    Thanks to everybody who participated in helping solving this issue.

    It solved as follow:

    1) Using RDBBMS 19.5 (template), I didn't install patch 30912308 as stated in the documentation and modifified accordingly the _* parameters.

    2) The RDBS 19.x repository will run on the same server that the server where EMCC13.4 will be installed.

    3) I ensured to have for the port ranges: ip_local_port_range=11000 - 6500

    As stated from the documentation (that is different from database settigs).

    4) I came across this error: ORA-01017

    Alhough I could connect using SQL*Plus and TNS name using the password given through the GUI to SYS and SYSMAN.

    It seems to be a bug described in Doc ID 1475282.1.

    I just reset the SYS password (with the same value) from SQL*Plus, pressed few time the "retry" from the GUI and the installation went further.

    5) The across this error: oracle.sysman.top.oms:The plug-in BI Publisher Configuration has failed its perform method.

    It seems also to be a bug described in Doc ID 2634802.1.

    Honestly, I think that Oracle should have tested EMCC13.4 beter before to release it for downlaod on OTN.

    Kind Regards

    MauritsGroenenberg

Answers

  • LauryLaury Posts: 1,618 Silver Badge
    edited June 2020 Accepted Answer

    Hi,

    Thanks to everybody who participated in helping solving this issue.

    It solved as follow:

    1) Using RDBBMS 19.5 (template), I didn't install patch 30912308 as stated in the documentation and modifified accordingly the _* parameters.

    2) The RDBS 19.x repository will run on the same server that the server where EMCC13.4 will be installed.

    3) I ensured to have for the port ranges: ip_local_port_range=11000 - 6500

    As stated from the documentation (that is different from database settigs).

    4) I came across this error: ORA-01017

    Alhough I could connect using SQL*Plus and TNS name using the password given through the GUI to SYS and SYSMAN.

    It seems to be a bug described in Doc ID 1475282.1.

    I just reset the SYS password (with the same value) from SQL*Plus, pressed few time the "retry" from the GUI and the installation went further.

    5) The across this error: oracle.sysman.top.oms:The plug-in BI Publisher Configuration has failed its perform method.

    It seems also to be a bug described in Doc ID 2634802.1.

    Honestly, I think that Oracle should have tested EMCC13.4 beter before to release it for downlaod on OTN.

    Kind Regards

    MauritsGroenenberg
  • MauritsGroenenbergMauritsGroenenberg Posts: 6 Red Ribbon
    edited October 2020

    I have more or less the same issue here. For the second time installation fails with invalid username/password for sysman during OutOfBox command execution. I am running on an oracle database 19.9 with a 19.5 medium size preconfigured template


    i can connect with sqlplus to the sysman in the pdb with the servicename I entered during installation. No retry button

    During db template installation in dbca , there is no entry for sysman password, so i enterd it my self the second time and tested it , remote_login_passwordfile      string   EXCLUSIVE, no special characters in the passwords


    Thanks for sharing this message because it costs me a lot of time and hard to believe these bugs....😯


    INFO: oracle.sysman.top.oms:The command run for OutOfBox is /u02/app/oracle/product/13.4.0/sysman/admin/emdrep/bin/RepManager -connect (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=ymir.greenberg)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=empdbrepos.greenberg))) -action outofbox -doTransx false  -pluginDepList {}  -repos_user SYSMAN -dbUser SYS -mwHome /u02/app/oracle/product/13.4.0 -mwOraHome /u02/app/oracle/product/13.4.0

    INFO: oracle.sysman.top.oms:processing arguments 

    INFO: oracle.sysman.top.oms:compiling arguments for validation

    INFO: oracle.sysman.top.oms:stty: standard input: Inappropriate ioctl for device

    INFO: oracle.sysman.top.oms:stty: standard input: Inappropriate ioctl for device

    INFO: oracle.sysman.top.oms: Enter SYS user password  : 

    INFO: oracle.sysman.top.oms:stty: standard input: Inappropriate ioctl for device

    INFO: oracle.sysman.top.oms:stty: standard input: Inappropriate ioctl for device

    INFO: oracle.sysman.top.oms:Verify : 

    INFO: oracle.sysman.top.oms:stty: standard input: Inappropriate ioctl for device

    INFO: oracle.sysman.top.oms:stty: standard input: Inappropriate ioctl for device

    INFO: oracle.sysman.top.oms:Enter SYSMAN user password  : 

    INFO: oracle.sysman.top.oms:stty: standard input: Inappropriate ioctl for device

    INFO: oracle.sysman.top.oms:stty: standard input: Inappropriate ioctl for device

    INFO: oracle.sysman.top.oms:Verify : 

    INFO: oracle.sysman.top.oms:Enter password for: SYS

    INFO: oracle.sysman.top.oms: Enter password for: SYSMAN

    INFO: oracle.sysman.top.oms: Error found: SQL exception - error has occured during the execution. The error trace message is 

    INFO: oracle.sysman.top.oms: java.sql.SQLException: ORA-01017: invalid username/password; logon denied

    INFO: oracle.sysman.top.oms:

    INFO: oracle.sysman.top.oms:The Connect Descriptor was (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=ymir.greenberg)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=empdbrepos.greenberg)))

    INFO: oracle.sysman.top.oms:.

    INFO: oracle.sysman.top.oms:The OutOfBox command execution completed with the status 255.

  • LauryLaury Posts: 1,618 Silver Badge

    Hi MauritsGroenenberg,

    It is already some time ago for me, and I moved to other kind of activities.

    You installation problem shows some similarities with mine.

    Unfortunately you didn't provide enough details to diagnose.

    To summarize, I had two problem: the dame password-issue that you, and plug-in BI Publisher Configuration error (although I do not needed the BI Publisher).

    I solved these two problems with these indications:

    1) EM 12c: Enterprise Manager Cloud Control OMS Installation Fails After Providing Database Credentials With "ORA-01017:

    invalid username/password; logon denied" (Doc ID 1475282.1)

    2) 13.4: OMS Install/Upgrade Fails During BIP Configuration (Doc ID 2634802.1)

    I hope this can help you.

    Yes, posting a thread for requiring help for the community can be tedious. But I think this is a necessity.

    The beter it is explained the beter the OTN community can help.

    Kind Regards

  • Russ CandfieldRuss Candfield Posts: 1 Green Ribbon

    I came across something similar when trying to use the 19c OEM template and running a silent ConfigGC.sh and a response file with the correct passwords - I was able to sqlplus from the OMS host across to the OMR host.

    I logged a case with Oracle - they suggested that I de-install the MW software and remove all the Repository objects. So is there any point in using the templates? Very disappointing when you try to make life easier and then you hit bugs and go back to the original install process.

Sign In or Register to comment.