Forum Stats

  • 3,838,281 Users
  • 2,262,350 Discussions
  • 7,900,575 Comments

Discussions

Discoverer Version - 11.1.1.7.0 with 19c Database and EBS 12.2.8

user12236222
user12236222 Member Posts: 4 Blue Ribbon
edited Jul 18, 2020 11:28PM in Discoverer

We are currently on Discoverer Version - 11.1.1.7.0 and we are using this (in Sustaining support mode) on Oracle Database 12c and Oracle EBS 12.1.3. We are planning to upgrade our Database and EBS versions to 19c and EBS R12.2.8 sometime later this year. We would like to know if this will work or there are known issues that this will fail. as per Document ID 2674063.1 : Oracle Discoverer 11.1.1.7.0 Certification With EBS R12.2, Discoverer 11.1.1.7.0 is certified and supported with EBS R12.2.8 . Please suggest.

«1

Answers

  • Alexander Pavlik
    Alexander Pavlik Member Posts: 44 Blue Ribbon
    edited Jun 12, 2020 2:09AM

    Hello

    We also configured Discoverer 11.1.1.7.0 with EBS 12.1.3 and database 11g. Here's installation document for reference

    Later we started to use the same installation with EBS 12.2.9 without issues.

    But our EBS 12.2.9 uses database 12.1.0.2, we haven't upgraded to 19c yet.

    Doc ID 2674063.1 warns about that: "Please be aware EBS 12.2.9 is certified for software versions (Example: Database 19c) that are NOT certified for use with Discoverer 11g."

    So it may and most probably will work, but it's not certified and will not be supported.

    We're planning to upgrade to 19c soon also, so I will let you know if discoverer will still work with the new db version.

    Regards,

    Alex

  • user12236222
    user12236222 Member Posts: 4 Blue Ribbon
    edited Jun 12, 2020 2:12PM

    Thank you very much Alex, for your response and providing the details. Please provide an update once you are able to test Discoverer with new DB version. BTW, since Discoverer is now de-supported, are you planning to migrate to a different tool / technology ?

    Thanks and Regards

    Somnath

  • sbeck-Oracle
    sbeck-Oracle Member Posts: 116 Employee
    edited Jun 23, 2020 8:16AM

    Sorry I didn't see this thread earlier.

    No, Discoverer is not certified or supported for use with a 19c database.  See Note 2598657.1 (Is Oracle Discoverer Certified With Oracle Database 19c).

    Suggest discussing your site's needs with your Oracle Salesperson to identify the right software replacement.

    Regards,
    Sharon

  • User_95R1Z
    User_95R1Z Member Posts: 2 Red Ribbon
    edited Jun 27, 2020 8:48AM

    Hi,

    Is it possible if create one intermediate database(having old Database version 11g/12c) where we will import the necessary table of Users and Responsibility details from 19c E-business Database which is required to initially to connect the Oracle Discoverer(11.1.1.7) Login Page? And if we create a Database link between Intermediate database to newly upgraded 19c E-business database, then is it possible to connect from Discoverer 11g to intermediate database having 11g/12c and run the reports from there ? If yes, then we can run the reports in Oracle Discoverer(11.1.1.7).

    Please answer my queries.

    Best Regards,

    Diptesh

  • sbeck-Oracle
    sbeck-Oracle Member Posts: 116 Employee
    edited Jul 8, 2020 12:44PM

    Technically it is possible; however it is not recommended as there is a performance hit.  It has never been tested and it may not work between two different Database versions.  You would need to ask a Database expert if it is feasible between the DB versions you will be using.

    Regards,

    Sharon

  • Alexander Pavlik
    Alexander Pavlik Member Posts: 44 Blue Ribbon
    edited Jul 18, 2020 11:28PM

    Hi Somnath

    We upgraded one of our EBS 12.1.3 databases to 19c and tested Discoverer with it also.

    It worked fine so far.

    But as Sharon said it's not certified or supported, so you don't know what to expect - later some issues may arise.

    Hope it helps you

    Regards,

    Alex

  • user12236222
    user12236222 Member Posts: 4 Blue Ribbon

    Thanks Alex for the update.

  • user12236222
    user12236222 Member Posts: 4 Blue Ribbon

    Hi Alex,

    Could you please suggest on the O/S you have for the R12.1.3 environment and if you have found any issues recently. We are also planning to upgrade our DB to 19c keeping the EBS version same (12.1.3).

    Thanks for your help.

    Thanks and Regards

    Somnath

  • User391889
    User391889 Member Posts: 5 Blue Ribbon

    Hi Alex,

    We are currently on 12.1.3 with Discoverer 11.1.1.7 and Database 12.1.0.2 (12c). We have a requirement to upgrade to 19c . My question is incase We are not able to connect through Discoverer Plus ,alternatively can we be able to connect to through Discoverer Desktop after upgrading 19c. Please advise and share your experience if you have upgraded to 19c

    Regards,

    Sanat

  • Alexander Pavlik
    Alexander Pavlik Member Posts: 44 Blue Ribbon

    Hi Sanat

    I think you'll be able to connect both ways, it was working fine for me

    Regards,

    Alex