Forum Stats

  • 3,770,327 Users
  • 2,253,095 Discussions
  • 7,875,403 Comments

Discussions

WARNING OGG-03056 data size exceeds the maximum target table

Omohei
Omohei Member Posts: 169 Blue Ribbon
edited Aug 19, 2020 6:14AM in GoldenGate

Hi all ,

I have below warnning  in replica report . i doubled check the source and target column the same in data type and width , the only diference  is   the source is Oracle DB 12.1 and Target MSSQL 2012

Any advice to clear the below warnning

2020-08-17 21:41:09  WARNING OGG-03056  Source table CISADM.HAYAT_ONLINE_STG col

umn CREATE_TIME data size exceeds the maximum target table dbo.RD_CCB_BILLS colu

mn CRE_DT size. Automatic truncation is enabled for all tables/columns without f

urther warnings.

Answers

  • Sreesha Nair-Oracle
    Sreesha Nair-Oracle Member Posts: 77 Employee
    edited Aug 17, 2020 9:46PM

    Hi,

    Which version of Goldengate are you using ?

    Are you using BATCHSQL parameter. If yes, could you comment that and check if you still get the same error.

    What message is recorded in the discard file ?

  • Omohei
    Omohei Member Posts: 169 Blue Ribbon
    edited Aug 18, 2020 8:08AM

    Hi ,

    I am using  ogg12.3 .not use batchsql.  dsc file did not report any messages since restart time

  • ORASCN
    ORASCN Member Posts: 1,825 Gold Trophy
    edited Aug 19, 2020 6:14AM

    Hey,

    CISADM.HAYAT_ONLINE_STG column CREATE_TIME

    target table dbo.RD_CCB_BILLS column CRE_DT

    could you please provide the description of both the tables

    Regards,

    Veera

  • I have the same problem but I am Oracle Ogg to Kafka

    WARNING OGG-03056 Source table BJSH.T4 column GEOM data size exceeds the maximum target table bjsh.T4 column GEOM size. Automatic truncation is enabled for all tables/co

    lumns without further warnings.


    {"table":"BJSH.T4","op_type":"I","op_ts":"2021-01-05 18:33:02.011919","current_ts":"2021-01-05T18:33:08.468000","pos":"00000000000000006703","after":{"MKT_ID":17,"NAME":"diit","CREATETIME":"2021-01-05 18:33:02.000000000","GEOM":""}}


    Field values for GEMO are not retrieved