Forum Stats

  • 3,728,222 Users
  • 2,245,576 Discussions
  • 7,853,386 Comments

Discussions

Session has expired. You must login again... error after about a minute using Oracle EM Express

Eslam_Elbyaly
Eslam_Elbyaly Member Posts: 4,142 Silver Trophy
edited September 2020 in Enterprise Manager

Hi,

I am using Oracle database 18c XE. Google Chrome Version 84.0.4147.135 (Official Build) (64-bit). After opening EM Express for about one minute I got "Session has expired. You must login again..." error. The problem happened with Opera browser Version:70.0.3728.106 too.

User_56XG3

Answers

  • 3870338
    3870338 Member Posts: 1
    edited September 2020

    I have the same issue using Database Express 12c on chrome. Using IE does not exhibit the issue. Refreshing the page or acknowledging the error results in the same error message in an infinite loop.

  • Eslam_Elbyaly
    Eslam_Elbyaly Member Posts: 4,142 Silver Trophy
    edited September 2020

    Same happens with me except for IE part. And that maybe because I've not tested it on it.

    Click " I have the same issue" link above, so that someone might pay attention to it.

  • Venkata Thiruveedhi-Oracle
    Venkata Thiruveedhi-Oracle Posts: 590 Employee
    edited September 2020

    Hi,

    What was the version of Chrome Browser you are using?

    Thanks,
    Venkat

  • user12141191
    user12141191 Member Posts: 1
    edited September 2020

    Same for me. My Chrome is 85.0.4183.102 (Official Build) (64-bit). No problem in IE.

    There is Doc ID 2651652.1 regarding this issue BTW, but my access to MOS has expired so can't tell what's inside.

  • Venkata Thiruveedhi-Oracle
    Venkata Thiruveedhi-Oracle Posts: 590 Employee
    edited September 2020

    From Google Chrome version 80, from February 2020, cookies will default into “SameSite=Lax,” which means cookies are only set when the domain in the URL of the browser matches the domain of the cookie — a first-party cookie.

    Previously, if SameSite wasn’t set, it defaulted to 'none' - enabling third-party sharing by default. Now, if the SameSite attribute isn’t set, the Chrome default is the first-party 'lax' setting.

    Chrome will not allow access to third party cookies unless the SameSite attribute is set to none and the secure flag is set. The SameSite attribute tells the browser if a cookie is available to first party and/or third party sites.

    Enter chrome://flags/#same-site-by-default-cookies in the URL bar of Chrome and Disable "SameSite by default cookies" . Relaunch Google Chrome after that.

    Or you can upgrade Chrome to the newer version(such as version:80.0.3987.162), it does not cause any problems with the default settings.

  • juarzvc
    juarzvc Member Posts: 1 Red Ribbon

    this solved my issue with EM on chrome.


    EM Console log out frequently when accessed using Google Chrome version 80 (Doc ID 2654206.1)


    SOLUTION

    Follow any of the steps below to access EM Console :

     1.Use different browser like Mozilla or IE to access the EM Console.

     2.Downgrade Chrome version to 79 and access the EM Console.

     3.As a workaround disable the following options on Chrome 80 browser.

    (You need to consult your OS Admin / Security Admin if these changes are permitted in your environment)

    In the address bar at the top of the browser enter: chrome://flags

    Search for SameSite

    Disable the following settings:

    SameSite by default cookies

    Cookies without SameSite must be secure

    For above changes to take effect, relaunch the Chrome browser.

    User_ZBEWI
Sign In or Register to comment.