Forum Stats

  • 3,825,014 Users
  • 2,260,455 Discussions
  • 7,896,382 Comments

Discussions

Key Vault 18.4 : Endpoint client installation issue

Hi,

I am trying to set up a KV with 2-node RAC within my VM test environment but having trouble at the KV client installation.

I have successfully set up the KV server up to the stage where I have to install the endpoint client in DB servers.

However, I have not been able to successfully install the client. I have tested so many time with bits of adjustments every time and was able to succeed only once using 'reboot all servers with the same config' method. (only once? very weird right?)

To double check, I deleted the client and tried the re-installation to isolate the cause of the problem but after another reboot the problem came back.

I am so fed up with the troubleshooting and ended up here asking for advice if anyone can provide regarding the problem.

The below is the commands and the environment I am using.

KV 18.4 server IP : 192.168.137.99

12c RAC1 IP: 192.168.137.20

12c RAC2 IP: 192.168.137.21

# su - oracle

$ export ORACLE_SID=RAC1

$ export ORACLE_BASE=/u01/app/oracle

$ export ORACLE_HOME=/u01/app/oracle/product/12.2.0/db

$ export OKV_HOME=/home/oracle/okvutil

$ /u01/app/oracle/product/12.2.0/db/jdk/jre/java -jar okvclient.jar -d /home/oracle/okvutil -v

[RAC1][email protected]:/home/oracle# /u01/app/oracle/product/12.2.0/db/jdk/jre/bin/java -jar okvclient.jar -d /home/oracle/okvutil -v

Detected JAVA_HOME: /u01/app/oracle/product/12.2.0/db/jdk/jre

Detected ORACLE_HOME: /u01/app/oracle/product/12.2.0/db

Detected ORACLE_BASE: /u01/app/oracle

Using OKV_HOME: /home/oracle/okvutil

Please set environment variables ORACLE_HOME, ORACLE_BASE, and OKV_HOME

consistently across processes.

Enter new Key Vault endpoint password (<enter> for auto-login):

Error occurred during install of Oracle Key Vault endpoint software. Check log files for more information. <<<<<<<<<<<<<<<<<<<<< the freaking error.

when I check the installation log...

....

Constructing wallet...

Generating okvclient.ora...

Symbolic link to /home/oracle/okvutil/conf/okvclient.ora created: /u01/app/oracle/okv/RAC1/okvclient.ora

Symbolic link to /home/oracle/okvutil/conf/okvclient.lck created: /u01/app/oracle/okv/RAC1/okvclient.lck

Wallet installation completed

okvutil version 18.4.0.0.0

Endpoint type: Oracle Database

Configuration file: /home/oracle/okvutil/conf/okvclient.ora

Server: 192.168.137.99:5696

Standby Servers:

Attempt to connect to 192.168.137.99 failed with: 28791

Error: Server Connect Failed                    <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< this seems to be the main cause of the error.

Sep 04, 2020 12:49:51 PM oracle.okv.platform.okvutil.OkvDeployHandler installOkvutil

SEVERE: Error while executing command: %/home/oracle/okvutil/bin/okvutil% install% -v% 3%

Sep 04, 2020 12:49:51 PM oracle.okv.platform.okvutil.OkvDeployHandler main

SEVERE: Error occurred during install of Oracle Key Vault endpoint software. Check log files for more information.

oracle.okv.platform.common.exception.CommonException: Error occurred during install of Oracle Key Vault endpoint software. Check log files for more information.

        at oracle.okv.platform.okvutil.OkvDeployHandler.installOkvutil(OkvDeployHandler.java:394)

        at oracle.okv.platform.okvutil.OkvDeployHandler.install(OkvDeployHandler.java:265)

        at oracle.okv.platform.okvutil.OkvDeployHandler.execute(OkvDeployHandler.java:1012)

        at oracle.okv.platform.okvutil.OkvDeployHandler.main(OkvDeployHandler.java:1207)

So, I have checked if the connection is really the problem as guided in How To Troubleshoot 'Server Communication Error' in OKV ? (Doc ID 2290716.1)

$ nc -z -v -w 1 192.168.137.99 5696

Connection to 192.168.137.99 5696 port [tcp/*] succeeded!   <<<<<<<<<<<<<<<<<<<<<<<<<<<<< succeed?!

$ /home/oracle/okvutil/bin/okvutil list

Error: Server Connect Failed     <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< but actual query to the KV server fails.

I have tried all sorts of combinations of adjustments and tests to identify the issue but it has not shed any light yet.

I even tried using KV 12.2.0.11 version but the client installations failed because of the very same error.

Also, my colleagues are experiencing the same issue and I wonder if the cause of the error falls in the scope outside the software.

I wonder if any of you out there has experienced this issue or if you can guide me to solve the problem, your help would be much appreciated!

Best regards,

Ryan

Tagged:

Answers

  • I had this issue, and I was able to resolve it by updating my sqlnet.ora file.

    I found that my sqlnet.ora file contained both

    WALLET_LOCATION

    SSL_CLIENT_AUTHENTICATION

    This is a test sever, and I have made changes to my lab network.

    Commenting out both of those settings in my SQLNET_ORA allowed OKV to properly configure on my host.


    I am not sure which one was the cause, but for others that are searching this error condition, that the fix that worked for me.