Forum Stats

  • 3,814,887 Users
  • 2,258,924 Discussions
  • 7,892,883 Comments

Discussions

SGD can't seem to login to Unix application server, login dialog keeps popping up

Jan-Oracle
Jan-Oracle Member Posts: 122 Employee
edited May 14, 2019 8:16PM in Secure Global Desktop

When SGD tries to launch an application on a Unix application server, it usually tries to connect with ssh -X to the application server. Under certain circumstances the ssh connection can take a long time, which results in the connection attempt from SGD timing out. Most likely this is due to a faulty DNS configuration on the application server and sshd using UseDNS yes, which is the default.

#<span class="Apple-converted-space"> </span>for server in $(awk<span class="Apple-converted-space"> </span>'/^nameserver/{print $2}' /etc/resolv.conf)do    echo<span class="Apple-converted-space"> </span>"${server} $(dig +short ${SGD_SERVER} @${server})"done192.0.2.1 ;; connection timed out; no servers could be reached152.68.154.3 10.150.6.24910.237.18.52 10.150.6.24910.254.202.139 ;; connection timed out; no servers could be reached# SGD_SERVER=<FQDN of SGD server><br/>

Changing the order of the name servers in /etc/resolv.conf or commenting out the unresponsive name servers solves this issue. Alternatively one can disable DNS for sshd by editing /etc/ssh/sshd_config and specifying UseDNS no.