Weblogic is going in unknow state — oracle-tech

    Forum Stats

  • 3,708,780 Users
  • 2,241,126 Discussions
  • 7,840,613 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Weblogic is going in unknow state

Amit_SharmaAmit_Sharma Posts: 14 Blue Ribbon

Dear All,

I am using the weblogic 10.3.6 with Java 7.

My application is developed in Primefaces and Spring.

After successfully startup weblogic is going in Unknown state.

Application is no longer accessible. Admin Console also become very slow.

I found below message in cosole and logs :

<1601815382043> <BEA-000449> <Closing socket as no data read from it on 192.168.201.51:37,516 during the configured idle timeout of 25 secs>


Please let me what is posisble cause and how to resolve this issue.


Thanks

-Amit

Tagged:

Answers

  • Ankur ShrivastavaAnkur Shrivastava Posts: 9 Green Ribbon

    Hello Amit,

    Do you see any other error apart from the above in admin server logs as the above is not a potential error message but a warning and it can be ignored. However, if your application is going to unknown state so it occurs as webLogic server tries to reuse sockets to improve performance, but sockets which are idle for a specified period are closed. The length of this period is controlled by the weblogic.client.socket.ConnectTimeout parameter, which specifies the amount of time the server waits before closing an inactive HTTP connection. This is set in the WebLogic Server startup script as one of the JAVA_OPTIONS. For example: -Dweblogic.client.socket.ConnectTimeout=XXX where XXX is the value in ms.


    To tune this property, test with different values to determine when the performance gain is retained but the number of closed socket warnings is minimized.

    -> Login to Admin Server

    -> Go to Managed sever->Protocols->HTTP->Duration: XXX seconds

    This property can also be set from the admin server GUI: Go to Managed Server -> Protocols -> HTTP -> Duration: XXX seconds


    In case the error persists, you may also need to change the login timeout by navigating through the admin server to config->tuning->login timeout. The default value is 5000ms so you can change it accordingly and restart the WL server and check the issue again.


    Regards,

    Ankur

Sign In or Register to comment.