Forum Stats

  • 3,824,767 Users
  • 2,260,416 Discussions
  • 7,896,309 Comments

Discussions

Looking for DRM help

Hi,

I am currently on HFM 11.1.2.4 (application type EPMA), in process of migrating to HFM 11.2. Due to unavailability of EPMA in the later version I am trying to use DRM to manage metadata. I followed the steps from Oracle Doc ID 2626317.1 (whitepaper) and converted my metadata file(.ads generated from EPMA file generator) to .txt

My .txt file starts like below. When I am trying to import this file into DRM I get an error saying "Line does not contain the number of columns defined for the section (7). Section will be skipped. Input line: Scenario|Scenario|#root" I get this error for every single line of my .txt file.

Metadata file -

[hier]

Scenario|Scenario|#root|Scenario||||true

Year|Year|#root|Year||||true

Period|Period|#root|Period||||true

View|View|#root|View||||true

Entity|Entity|#root|Entity||||true

Value|Value|#root|Value||||true

Account|Account|#root|Account||||true

ICP|ICP|#root|ICP||||true

Currency|Currency|#root|Currency||||true

Custom1|Generic|#root|Custom1|C1|From|Large|true

Custom2|Generic|#root|Custom2|C2|To|Large|true

Custom3|Generic|#root|Custom3|C3|None|Large|true

Custom4|Generic|#root|Custom4|C4|None|Large|true

SecurityClass|SecurityClass|#root|SecurityClass||||true

ConsolidationMethod|ConsolidationMethod|#root|ConsolidationMethod||||true

Alias|Alias|#root|Alias||||true


[relation]

Scenario|ACTUAL|Y|MTD|YTD|YTD|YTD|N|2|Y|Y|S_ACTUAL|O|YTD||||Actual||||||||||||||||||||||||||||||||||||

Scenario|PLAN|Y|MTD|Periodic|Periodic|Periodic|Y|1|N|N|S_FCST|N|MTD||||Plan||||||||||||||||||||||||||||||||||||

Scenario|MARFCST|Y|MTD|Periodic|Periodic|Periodic|Y|1|N|N|S_FCST|N|MTD||||March Forecast||||||||||||||||||||||||||||||||||||

Year|2006|Y|||||||||||||||||||||||||||||||||||||||||||||||||||

Year|2007|Y|||||||||||||||||||||||||||||||||||||||||||||||||||

and so on

Answers

  • Krishna Chukkaluru
    Krishna Chukkaluru Member Posts: 165 Silver Badge

    Hello,


    Before running the DRM import, goto Columns tab and select Hierarchy section from drop down. Verify the columns are selected appropriately and in the order as defined in your text file. You may have to do this in other sections also.


    Regards,

    Krishna C

  • User_RUHNJ
    User_RUHNJ Member Posts: 54 Blue Ribbon

    Thanks Krishna. I did realize that columns were selected incorrectly and I am reviewing the same. Are there any guide to convert EPMA file generator's .ads file into a .txt format that can be straight away imported into DRM. I did install 30695700: EPMA ADS FILE CONVERSION UTILITY FOR EPM 11.2 but it is not of much help. The .txt file generated through this utility is not getting imported into DRM. Looks like it needs some tuning. If there are any guides/documents around this I can refer to them

  • Krishna Chukkaluru
    Krishna Chukkaluru Member Posts: 165 Silver Badge

    I have experienced the same that the file generated by conversion utility did not import into DRM because of the reason I mentioned. I had to manually modify the DRM import to accommodate as the per the order displayed in text file.


    Regards,

    Krishna

  • User_RUHNJ
    User_RUHNJ Member Posts: 54 Blue Ribbon

    Finally I was able to import the metadata file after manually updating it. Then I made minor changes to the dimension hierarchy and exported the same. I am unable to load this DRM export file into Classic HFM. Do I need to perform additional steps prior to this? I am following Doc ID 2626317.1

  • Krishna Chukkaluru
    Krishna Chukkaluru Member Posts: 165 Silver Badge

    Hi,

    The document has section "DRM Export Metadata" that explains how you can export the metadata. Hope you have followed that. And I would recommend to export metadata file from any existing HFM application through Extract Application elements. Then compare it with your DRM export of HFM metadata file and accordingly you can modify your exports and book.

    Regards,

    Krishna

  • User_RUHNJ
    User_RUHNJ Member Posts: 54 Blue Ribbon

    I configured my 11.2 DRM export to look very similar to 11.1.2.4's APP file. Only difference between the two is former one is alphabetically sorted. I am able to scan 11.1.2.4 metadata file in 11.2 system successfully where as I get an error for the metadata file exported from 11.2 DRM. Below is the screenshot of the lines that is kicking out error message "Line: 5641, Error: Member name has invalid characters, is too long, or is empty

    |0643EC

    >>>>>>" in metadata load scan.

    DRM 11.2 Export


    11.1.2.4 Export


    I also see follow error message at the end of metadata scan logError: Member defined but not referenced in the hierarchy

    Account

    >>>>>>!HIERARCHIES=Account"

    Wondering if there is any issue with format of my DRM export file. Is there something around encoding that should be considered here?


  • User_QLMXY
    User_QLMXY Member Posts: 14 Red Ribbon

    Hi User_RUHNJ,

    Could you able to help me with the process you have followed.

    I am failing at the import file process, i tried to arrange the properties in the same order shown in the .txt file, still i am getting the same error as you had.like below:

    Line does not contain the number of columns defined for the section (65). Section will be skipped.

    i deleted the mentioned column, and i am getting for another. and i have deleted that one as well, again getting the error with the new line number.

    is there is any ideal way or bypass procedure if you find, kindly guide me.


    Regards,

    P