issue installing grub2-efi-aa64 — oracle-tech

    Forum Stats

  • 3,708,768 Users
  • 2,241,125 Discussions
  • 7,840,600 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

issue installing grub2-efi-aa64

User_I6CNCUser_I6CNC Posts: 2 Green Ribbon

Hi


I have a raspberry pi. i had centos installed on there. now trying to port over to oracle linux

when i run this

 dnf install grub2-efi-aa64



i get


Error unpacking rpm package grub2-efi-aa64-1:2.02-90.0.1.el8.aarch64

 Cleanup     : grub2-tools-extra-1:2.02-87.0.1.el8_2.aarch64                                  6/9

error: unpacking of archive failed on file /boot/grub2/grubenv;5fe0a07a: cpio: symlink

error: grub2-efi-aa64-1:2.02-90.0.1.el8.aarch64: install failed



now I am stuck. I tried the version before same issue - quick google says / implies it because one of the directories is symlink .. its not


 ll /boot/ /boot/grub2 / /boot/grub2/grubenv -d

dr-xr-xr-x. 18 root root 4096 Dec 21 15:48 /

drwxr-xr-x. 8 root root 16384 Jan 1 1970 /boot/

drwxr-xr-x. 2 root root 8192 Nov 6 06:56 /boot/grub2

-rwxr-xr-x. 1 root root 1024 Dec 22 00:12 /boot/grub2/grubenv


So now what to do ?

Comments

Sign In or Register to comment.