Few user backup is not coming with Export Data Pump command — oracle-tech

    Forum Stats

  • 3,707,909 Users
  • 2,240,908 Discussions
  • 7,839,919 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Few user backup is not coming with Export Data Pump command

User_HZX9UUser_HZX9U Posts: 5 Newbie
edited January 8 in Secure Backup

Hi,

I have used the below command to take full database backup

expdp 'username/password as sysdba' DIRECTORY=OracleDB_Backup  DUMPFILE=Oracle_DB_Backup"%date:~7,2%%date:~4,2%%date:~10,4%".dmp LOGFILE=log_Oracle_DB_Backup"%date:~7,2%%date:~4,2%%date:~10,4%".log full=y

All the database backup are coming properly.

But when I'm creating any new user and adding tables in it including data, and after that, I run this command so that the latest user backup is not coming.

Please let me know why I'm getting this issue and is there any possible solution for this.

Also, I have attached the log file below.


Answers

  • Sunny kichlooSunny kichloo Posts: 2,412 Gold Trophy

    If possible try to use system user to perform export and let us know if you are still facing the same issue.

  • User_HZX9UUser_HZX9U Posts: 5 Newbie

    I have tried with system credential, since my system password contains special characters such as @ sign. Can you tell me how to avoid expdp from misinterpreting my login string?

    Here is an example of what my login string looks like:

    expdp SYSTEM/[email protected]! DIRECTORY=OracleDB_Backup  DUMPFILE=Oracle_DB_Backup.dmp LOGFILE=log_Oracle_DB_Backup.log full=y

    When I run this above command I'm getting this error:

    Export: Release 12.1.0.2.0 - Production on Fri Jan 8 02:30:07 2021

    Copyright (c) 1982, 2014, Oracle and/or its affiliates. All rights reserved.

    UDE-12154: operation generated ORACLE error 12154

    ORA-12154: TNS:could not resolve the connect identifier specified

  • User_HZX9UUser_HZX9U Posts: 5 Newbie

    Hi,

    Using the escape character in the password, I'm now able to run the export with the system user but still, I'm not getting the latest user backup.

    expdp SYSTEM/\"[email protected]!\"@orcl DIRECTORY=OracleDB_Backup  DUMPFILE=Oracle_DB_Backup"%date:~7,2%%date:~4,2%%date:~10,4%".dmp LOGFILE=log_Oracle_DB_Backup"%date:~7,2%%date:~4,2%%date:~10,4%".log full=y

    Below is the log file attached

    Please let me know if there is any other solution.

  • user4099183user4099183 Posts: 2 Blue Ribbon

    @User_HZX9U There is no error in the export log.

    Are only new users skipped from the export or are other schema also missing ?

  • User_HZX9UUser_HZX9U Posts: 5 Newbie

    Only new users are skipped from the export.

  • user4099183user4099183 Posts: 2 Blue Ribbon

    And if you connect with sqlplus

    sqlplus SYSTEM/\"[email protected]!\"@orcl

    select username,sum(bytes)/1024/1024/1024 as Gb,count(*) as NumberOfSeg from dba_segments group by username;

    you see the new schema and the sum of bytes and count of segments are as expected ?

  • Dieter E. HenigDieter E. Henig Posts: 7 Blue Ribbon

    please try

    FLASHBACK_TIME=sysdate

    or simply

    CONSISTENT=Y

Sign In or Register to comment.