Forum Stats

  • 3,733,808 Users
  • 2,246,823 Discussions
  • 7,856,882 Comments

Discussions

Error launching Fusion Middleware Composer (fmw-composer.sh)

Aminu
Aminu Member Posts: 13 Blue Ribbon
edited February 19 in WebLogic

Hi,

I have a 2-node Weblogic Server 12.2.1.0 cluster installed on Solaris SPARC 11.3 (64-bit). I intend to patch the 2-node cluster with opatchauto so as a requirement I have to generate a Topology File using Fusion Middleware Composer. However, I get the error below when I try to launch FMW-Composer using instructions in weblogic documentation:

[email protected]:/u01/fmw/oracle_common/bin$ echo $JAVA_HOME

/u01/software/jdk1.8.0_131

[email protected]:/u01/fmw/oracle_common/bin$ ./fmw-composer.sh

Error: Could not find or load main class oracle.fmwplatform.tools.topeditor.TopologyEditor

FMW-COMPOSER exited with code: 1.

Question 1: Is there something I am missing? I have also tried running FMW-Composer on another standalone weblogic installation of the same version and I get the same error. Please note that I have properly set and tested DISPLAY environment variable and I am able to launch GUI programs like xclock. I need some assistance to get this utility running.

Question 2: Can I alternatively just use opatch (instead of using opatchauto, which needs the topology file) to patch each node separately?

Thank you

Sign In or Register to comment.