Forum Stats

  • 3,727,090 Users
  • 2,245,319 Discussions
  • 7,852,584 Comments

Discussions

"Error setting up base repository" when using OracleLinux-R8-U3-x86_64-dvd

User_VH8NJ
User_VH8NJ Member Posts: 3 Green Ribbon

Hello. I have tried to install Oracle Linux but I came across the "Error setting up base repository". Then I added in the installation source https://yum.oracle.com/​repo/​OracleLinux/​OL8/​baseos/​latest/​x86_64. It did accept and I select gnome as the GUI in the server section.


then it proceed with the installation, but after the restart it gave a black screen with a command prompt. I tried to install gnome using the command line but it was reporting that it cant find the repository to find the packages.

Note: I want to install Oracle Linux 8.3 as a workstation to test it.

Kindly advise me.


Thanks,  

Tagged:

Answers

  • Avi Miller-Oracle
    Avi Miller-Oracle Senior Solution Architect, Oracle Cloud Infrastructure Developer Adoption Melbourne, AustraliaPosts: 4,795 Employee

    The easiest solution is to download the Full ISO from https://yum.oracle.com/oracle-linux-isos.html instead of the Boot ISO. I know its much larger, but everything you need to install is in that image.

    If you want to use yum.oracle.com to install, you need to create three repos: the one you already have, as well as the following two:

    • ol8_appstream: https://yum.oracle.com/repo/OracleLinux/OL8/appstream/x86_64
    • ol8_UEKR6: https://yum.oracle.com/repo/OracleLinux/OL8/UEKR6/x86_64
  • User_8Z6K9
    User_8Z6K9 Member Posts: 6 Green Ribbon

    I'm having a similar problem with the full ISO (OracleLinux-R8-U3-x86_64-dvd.iso).

    Now that we've proved out conversion from CentOS to Oracle Linux, I'm working on converting our unattended offline kickstart installation. I burned the aforementioned ISO to a USB stick, dropped in our kickstart config, and tried to install. This failed on the installation sources, which in our ks.cfg is configured as follows:

    repo --name=AppStream --baseurl=file:///run/install/repo/AppStream
    

    The same paths exist on the OL stick. I next disabled cmdline and ran the graphical installer with the same configuration. In the Installation Source menu, "On the network" was the only available option and the above path was configured under "Additional repositories," but the installer continued to flag the installation source.

    Then I thought I should just run the graphical installer without our configuration and grab the anaconda-ks.cfg to figure out what I need to change. So I burned the ISO again and tried to run the stock graphical installer. It still flags installation source, but if I don't have a network connection I see an "ISO file" option. Here I can select the USB stick, but installation source is still flagged. I see the option to "Choose an ISO" but I'm not sure what I would select here.

    EDIT: In the media.repo file from that ISO the Oracle Linux version is listed as 8.2.0. Maybe that's a clue? Fixing it there doesn't correct the problem.


    Apologies if this should be a separate discussion.

Sign In or Register to comment.