Forum Stats

  • 3,728,470 Users
  • 2,245,631 Discussions
  • 7,853,548 Comments

Discussions

Setting Up Standalone System Via Kickstart -- OEL 8

EvilEuro
EvilEuro Member Posts: 1 Green Ribbon

Hello,

With the whole RHEL/CentOS 8 debacle happening, I have been tasked with investigating OEL 8 to see how it suits our needs heading into the future.

With RHEL/CentOS 6 and 7, we had a "self-contained" kickstart CD/USB key. We needed this for standalone systems and it works great. You make your choice between the selections (single disk, single disk with LUKS, RAID setup, RAID setup with LUKS), and the installation is automated and proceeds from there.

However... with verison 8.x on OEL, no such luck. While the .iso builds with our amendments to isolinux.cfg, grub.cfg., and our kickstart files, the system itself doesn't initialize and build. Instead, after launching, it hangs during the initialization process, always going through a loop where it's looking for Network Manager to establish a connection.

Thing is, these are systems in a standalone environment. They're just not going to have a network connection available to them at build time (or ever).

Is there something I need to put in our kickstart file to eliminate or bypass the network manager trying to find a non-existant DHCP connection? Otherise I get the dreaded dracut timeout error.

Any help or guidance on this is appreciated.

Comments

  • Avi Miller-Oracle
    Avi Miller-Oracle Senior Solution Architect, Oracle Cloud Infrastructure Developer Adoption Melbourne, AustraliaPosts: 4,796 Employee

    I would recommend adding network --no-activate to your Kickstart which should hopefully make Anaconda not try to activat the default device,

    Reference: https://docs.centos.org/en-US/8-docs/advanced-install/assembly_kickstart-commands-and-options-reference/#kickstart-commands-for-network-configuration_kickstart-commands-and-options-reference

  • EvilEuro
    EvilEuro Member Posts: 1 Green Ribbon

    Thanks for the reply.


    network --no-activate doesn't seem to be working as I am still getting errors where kickstart is trying to find a DHCP server. This is all in a VM, so I can redo my kickstart file, rebuild the ISO, and try again.

    If I do it with the vNIC disabled, I just get scrolling messages stating that eth0 link is not ready. When I re-enable the vNIC, I get the same messges regarding DHCP.

    I've enclosed some screenshots of the journalctl entries to show what I'm seeing.


  • EvilEuro
    EvilEuro Member Posts: 1 Green Ribbon

    From going through the CentOS Forums it looks like I will need to add the repo information to the our kickstart config files. Will update to see if that helps solve the issue.

  • EvilEuro
    EvilEuro Member Posts: 1 Green Ribbon

    If I use the network --no-activate option, I end up getting "IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready" errors.

    This occurs whether or not I add --noipv6 and/or --noipv4 to the kickstarter file as well.

    I also get the infamous /dev/root does not exist message at the very end, which is odd because I do know the disc label is correct (linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=OL-8-3-0-BaseOS-x86_64 inst.ks=file:/ks/ks.cfg rdblacklist=nouveau net.ifnames=0 biosdevname=0)

    Not quite sure what's happening there, but I keep getting the issue with IPv6 now.

Sign In or Register to comment.