Forum Stats

  • 3,840,070 Users
  • 2,262,563 Discussions
  • 7,901,143 Comments

Discussions

Big Sur problems with NLS

user6236999
user6236999 Member Posts: 2 Red Ribbon
edited Jun 10, 2021 1:47PM in TimesTen In-Memory Database

I've tried three different version of the TimesTen client (11.2.2.8.0, 11.2.2.8.9, and 18.X) on a Mac running OS/X. After working through all of the SIP security stuff on installation, I get more or less the same error with each driver "Unable to load NLS initialization data from /nls/data".

Output from dtrace seems to indicate that the driver is attempting to load the NLS data from the root directory.

1003/0x4863: open("/nls/data/lx2boot.nlb\0", 0x0, 0x0)         = -1 Err#2

1003/0x4863: open("/nls/data/lx1boot.nlb\0", 0x0, 0x0)         = -1 Err#2

1003/0x4863: stat64("/nls/data/lx0boot.nlb\0", 0x70001026EA20, 0x0)      = -1 Err#2

Does anyone know the driver determines where to look for these files?

FWIW, I'm using the following settings:

-Djava.library.path=/Users/<username>/TimesTen/tt1122/lib

TIMESTEN_HOME=/Users/<username>/TimesTen/tt1122

Answers

  • ChrisJenkins-Oracle
    ChrisJenkins-Oracle Member Posts: 3,409 Employee

    Hi,

    I've been running TimesTen 18.1.4 on Big Sur since 11.1 (and Catalina before that) and have never had to do anything with SIP etc. Why do you find you need to do that? What are the symptoms?

    TimesTen 18.1 (please don't use 11.2.2, it is very old now) uses the value for the TIMESTEN_HOME environment variable to determine where to load the NLS data from.Maybe you didn't export the TIMESTEN_HOME variable?

    export TIMESTEN_HOME=/Users/Shared/TimesTen/instances/tt181

    or maybe the environment variable is not making it through to whatever process is trying to use TimesTen; is this from an application or just something like ttIsqlCS?

    Note that the recommended way to set all of the environment variables for TimesTen is to use the provided script:

    source <tt_instance_home>/bin/ttenv.sh

    Also note that the OS user who is running the TimesTen application or utility needs to have suitable permissions on the TimesTen instance and installation trees otherwise it will not be able to read the files.

    Chris