Forum Stats

  • 3,759,435 Users
  • 2,251,543 Discussions
  • 7,870,635 Comments

Discussions

Why is Dyn Updater all of a sudden spawning 20+ UAC prompts on my computer?

User_LB663
User_LB663 Member Posts: 8 Green Ribbon

I use Dyn Updater to update my dynamic IP. Has worked without issues. Now today for some unexplained reason, a bunch of UAC prompts were spawned by Dyn Updater regarding making some sort of change on my system.

I had to manually close some 20 of them. Then a few hours later it happened again.

The patch notes for this application say as of 2010 it was updated to allow non-admin users to perform some activities with the use of UAC prompts, but I'm an administrator on my machine and I've been using this for years since 2010 so I don't understand why this is occurring.

Anyone have any ideas?

User_3ELIOUser_241MUUser_WK0HO
«1345678

Answers

  • User_5JPLL
    User_5JPLL Member Posts: 6 Green Ribbon

    Only 20? I got 91. Also looking for a solution. My guess is the demon is hanging or stops responding and it keeps trying to restart it. I assume that it can't reach the update server. But that's just a guess. Would like to know why this suddenly started.

  • User_WVUAJ
    User_WVUAJ Member Posts: 1 Green Ribbon

    So do I. When restarted, DYNupdater does not connect to the server.There seems to be a problem connecting or logging in.

  • User_GM7MT
    User_GM7MT Member Posts: 5 Green Ribbon
    edited Jul 20, 2021 2:38PM

    I'm having the same issue, can anyone from Oracle give us a solution/workaround or at lease a root cause of why is this happening suddenly?

  • User_18JDJ
    User_18JDJ Member Posts: 1 Green Ribbon

    I, as well as a number of clients which I've setup Dyn DNS have the same issues starting at 15:47 yesterday afternoon (Jul 19, 2021) according to the daemon and frontend logs.

    Try clicking "Remove Account" from the Dyn Updater.

    Select the account "none".

    In my case, my current account appear back again and the Host Active turned green.

    Hope this helps someone.

  • User_LB663
    User_LB663 Member Posts: 8 Green Ribbon
    edited Jul 20, 2021 9:39PM

    For what it's worth, my host already reports green. Was yours prior to removing/readding?


    Also 20+ was being humble. It does spawn a hell of a lot more than that like the above stated LOL.

    Seems it is indeed crashing at some point (only a couple of these events in my event viewer), but the Dyn logs show a buttload of the following events:


    2021-07-20 07:26:10,496 - frontend - WARNING - Failed to receive API response from backend. Attempting to restart daemon.

    2021-07-20 07:26:10,841 - daemon - INFO - Insufficient privileges, relaunching as admin.


    ------Event Log-------

    Log Name:   Application
    Source:    Application Error
    Date:     7/20/2021 7:48:08 AM
    Event ID:   1000
    Task Category: (100)
    Level:     Error
    Keywords:   Classic
    User:     N/A
    Computer:   DESKTOP-MATTHEW
    Description:
    Faulting application name: dyn_updater.exe, version: 5.5.0.0, time stamp: 0x50afcaea
    Faulting module name: KERNELBASE.dll, version: 10.0.19041.1110, time stamp: 0xc830c52d
    Exception code: 0x40000015
    Fault offset: 0x0012b4b2
    Faulting process id: 0x68c0
    Faulting application start time: 0x01d77d1b19179d38
    Faulting application path: C:\Program Files (x86)\Dyn\Updater\dyn_updater.exe
    Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
    Report Id: 2bd88df3-8166-46c1-a833-27b0f0d88280
    Faulting package full name: 
    Faulting package-relative application ID: 


  • User_LB663
    User_LB663 Member Posts: 8 Green Ribbon

    I also have the following event, which suggests it's trying to run a number of python scripts, including updating the NIC, but I have this setting disabled as I do not wish to have my NIC set to use DynDNS servers. Not sure if it's related or not.

    Log Name:   Application
    Source:    DynUpdater
    Date:     7/20/2021 4:05:34 AM
    Event ID:   3
    Task Category: None
    Level:     Error
    Keywords:   Classic
    User:     N/A
    Computer:   DESKTOP-MATTHEW
    Description:
    The instance's SvcRun() method failed 
    Traceback (most recent call last):
     File "/win32serviceutil.py", line 835, in SvcRun
     File "/lib\daemon\windows.py", line 230, in SvcDoRun
     File "/lib\daemon\windows.py", line 309, in main
     File "/lib\daemon\nicupdate.py", line 639, in check_and_send_updates
     File "/lib\daemon\nicupdate.py", line 419, in _get_hosts_to_update
     File "/lib\daemon\nicupdate.py", line 361, in _get_host_addresses
     File "/lib\daemon\nicupdate.py", line 621, in get_ipaddress
    AttributeError: 'NoneType' object has no attribute 'version' 
    %2: %3


  • User_CWQ65
    User_CWQ65 Member Posts: 1 Green Ribbon

    Happening to me as well, no need to repeat the details others already have. This is infuriating and we need it to stop pronto!

    User_LB663Jon W.
  • User_LB663
    User_LB663 Member Posts: 8 Green Ribbon
    edited Jul 20, 2021 9:46PM

    I've submitted an email to support. Will see what they say. I suggest everyone else do the same.


    https://account.dyn.com/support/contact/email.html

  • User_LB663
    User_LB663 Member Posts: 8 Green Ribbon

    So far this is what's being said. I do not understand the direction as the service is already running as local SYSTEM so it should already be running with the highest level privileges possible.

    I would highly suggest NOT disabling UAC entirely.


    Dyn Support <[email protected]>

    5:48 PM (4 minutes ago)

    ### Do Not Place Your Reply Below This Line ###


    Good afternoon Matthew,


    In looking into this problem, this elevation means that this application needs to be run as the administrator.


    Also, you can navigate to C:\program files (x86)\Dyn\updater

    and find dyn_updater.exe

    right-click on it and select properties

    Select the Compatibility tab

    select the box Run this program as an administrator

    select apply

    then ok.



    If this does not work, you can disable UAC until the bug has been fixed:

    UAC off

    To turn off UAC:

    Type UAC into the Windows Start menu.

    Click "Change User Account Control settings."

    Move the slider down to "Never Notify."

    Click OK and then restart the computer.



    Thank you for your patience.

  • Jon W.
    Jon W. Member Posts: 4 Green Ribbon

    I'm fighting the same thing, I thought maybe it was a change with the July cumulative update, but uninstalling it presented no relief. I'd already tried setting the .exe to run as admin, but that appears to actually not launch it at all, oh, and running the front-end as admin prevents access to the configuration data as that's apparently only available when running in normal user contest. I'm curious to see what response I get when support replies to the ticket I opened today as well.