Forum Stats

  • 3,757,485 Users
  • 2,251,236 Discussions
  • 7,869,842 Comments

Discussions

runcat.sh syntax issues with -type

Hi All ,

I am trying to export report logical sql using runcat.sh but it is giving error as below.

Error : Bad option Specify -fields for -type

Below is the syntax I am using. reference site (https://www.rittmanmead.com/blog/2014/01/automated-regression-testing-for-obiee/)

./runcat.sh -cmd report -online http://obidev1:9502/analytics/saw.dll -credentials creds.txt -forceOutputFile output.lsql -folder "/shared/BI Internal/samplereport" -type "Analysis" "SQL"

we are using OBIEE 12c.

Please help me to resolve the issue.


Thanks,

Bharath

Tagged:

Answers

  • Gianni Ceresa
    Gianni Ceresa Managing Director | Oracle ACE Director Member Posts: 6,293 Gold Crown

    Try running ./runcat.sh -cmd report -help

    It will gives you the answer you are looking for. The blog post is from 2014, at that time it was 11g. 12c changed various things, but the help command will tell you exactly what it expects for the -fields parameter (which is dependent on the value of -type as well).

    Christian Berg-Oracle
  • Was your question answered to your satisfaction? If yes, then please close this thread following the instructions here: https://community.oracle.com/tech/apps-infra/kb/articles/22-accept-an-answer-as-correct

    It will visibly mark the whole thread as "Answered", providing visual indication and help to all other users that it contains a viable solution or pertinent closure.

    If your question was not answered, please add a detailed statement on why it's not answered, open points, dead-ends, counterindications etc.

    Also it always helps provide more detailed information on your issue and setup in order to facilitate the community helping you. This includes, but is not limited to:

    • full and exact product name like "Oracle Analytics Cloud" or "Oracle Analytics Server" or "Business Intelligence Applications"
    • full and exact version number including Bundle Patches like "5.5.0.0.210709"
    • full and exact host operating system version, browser, database etc.
    • pertinent screenshots
    • step-by-step guide to what you did in order to reproduce

    Cheers,

    Christian

  • Joel Acha
    Joel Acha Member Posts: 1,370 Gold Trophy

    In addition to the comments from @Gianni Ceresa & @Christian Berg-Oracle , try taking the double quotes off the Analysis type and adding the fields parameter:

    ./runcat.sh -cmd report -online http://obidev1:9502/analytics/saw.dll -credentials creds.txt -forceOutputFile output.lsql -folder "/shared/BI Internal/samplereport" -type Analysis -fields "SQL"