Forum Stats

  • 3,759,504 Users
  • 2,251,554 Discussions
  • 7,870,682 Comments

Discussions

Some packages and dimensions disapear after deploying the .rpd

Hello everyone,

i am using OBIEE 12.2.1.3.0 , when i add a new package or a new dimension to a package and i upload the .rpd everything is good and when i check into the obiee server i find the new features i added , but 15 min later while i am using OBIEE, all the new features disapears

i don't understand

Thank you in advance

Answers

  • Christian Berg-0racle
    Christian Berg-0racle Managing Director Member Posts: 9,439 Gold Crown

    a) What exact version? Did you really stay on 12.2.1.3.0 and never patched?!

    b) 12.2.1.3 is quite old and should be updated in any case

    c) What's a "package" in this context?

  • John305
    John305 Member Posts: 132 Red Ribbon

    a) it was patched , i am waiting for the patch list and i will tell you

    b) a package means a "domain" or a "dimension"

    i added a dimension to a domain , i uploaded the rpd and 10 min later , the dimension disapeared from the domain

  • Gianni Ceresa
    Gianni Ceresa Managing Director | Oracle ACE Director Member Posts: 6,303 Gold Crown

    Is a "domain" a subject area? Or is it a business model? Or both?

    When you say disappeared, you mean you don't see the new objects anymore in the front-end? Or that if you download the RPD from your OBIEE server the changes aren't there anymore?

    How did you do the changes? Fully offline? How did you deploy the RPD? Did you restart something at some point?

  • John305
    John305 Member Posts: 132 Red Ribbon

    Yes its a subject area ?

    I don't see the new objects in the front-end , when i add a subject area per example i upload the .RPD (Fully offline) i see the new subject area for few minutes ( or a new dimension that i added to an existing subject area ) then i disapear and i cant see it it my front-end.

    we restarted all the services after but nothing changed

  • John305
    John305 Member Posts: 132 Red Ribbon

    The .Rpd changed are correctly saved , i just loaded the metadata and the new features appears again , but they can disapear at any moment.


    it's like there is a problem of synchronisation between the front end and the .Rpd

  • Gianni Ceresa
    Gianni Ceresa Managing Director | Oracle ACE Director Member Posts: 6,303 Gold Crown

    Did you try adding something else new in the RPD? Same issue? Dropping and re-adding that object it still behave the same?

    Did it ever happen before?

    (Yes, it's really random tests to try to isolate the case and see if it can be reproduced all the time or it has been a single occurrence issue).

  • John305
    John305 Member Posts: 132 Red Ribbon

    Yes i tried to add another dimension to an existing subject area , same issue the new added features disapear.

    and if i reload the rpd another time , it appears for a certain time then it disappear , its random.

    I don't know how to fix it.

  • Christian Berg-0racle
    Christian Berg-0racle Managing Director Member Posts: 9,439 Gold Crown

    "I don't know how to fix it."

    We don't know your exact version, we don't know the exact platform you're running on, so we can't say whether it's a bug and whether this has been solved (if it was a bug).

    That's why these are the first things stated with a post in here. And precisely because bundle patches contain....patches.

    Also the version you're on dates back to 2017 and many similar "weird" behaviours were eliminated in the meantime. The current version of OAS is 5.9.0 and yearly upgrades with quarterly patching is standard. Not multi-year stays on outaded versions. This ensures you automatically get all new features and bug fixes and don't have to bother with legacy issues which don't exist anymore. Patching and upgrading isn't a big deal anymore.

  • John305
    John305 Member Posts: 132 Red Ribbon

    Good morning ,


    the patch installed is  33064699