Forum Stats

  • 3,770,097 Users
  • 2,253,066 Discussions
  • 7,875,311 Comments

Discussions

vmware kernel - kerner source mismatch?

StanByk
StanByk Member Posts: 10 Blue Ribbon

Hi everyone,

Since a while I am struggling with getting vmware to work on OL7. After an update (yum update) vmware wants to recompile some kernel module and fails.

when I run uname -r it tells me I have this installed: 5.4.17-2136.300.7.el7uek.x86_64

when I run yum install kernel-devel it tells me: Package kernel-devel-3.10.0-1160.45.1.el7.x86_64 already installed and latest version

Shouldn't these two things match?

Lastly, an rpm -qa | grep kernel yields (among others):

kernel-uek-devel-5.4.17-2136.300.7.el7uek.x86_64


I am totally confused as this is way beyond my skill level. I am not even sure I am providing the necessary info here. I would appreciate any help I could get. Let me know if I should provide any other info.

Thank you all in advance!

Answers

  • David Gilpin-Oracle
    David Gilpin-Oracle Principal Product Manager, Oracle Linux and Virtualization Frisco, TXPosts: 32 Employee

    Oracle Linux ships with two kernels.

    The default (and the one you are running, based on the output of your uname command) is the Oracle UEK. It is based on upstream 5.4.17 code.

    The other kernel is the so-called "Red Hat Compatible Kernel", nicknamed RHCK. It is THE RHEL kernel source code with trademarks and other encumbrances removed. In RHEL 7 their kernel is based on upstream 3.10.0

    Compiling kernel modules with the UEK requires the kernel-uek-devel package to be installed. You can install this by running:

    # yum install kernel-uek-devel

    After installing kernel-uek-devel reboot the OL instance before attempting to recompile the VMware tools.

  • It looks like you already have the correct kernel-uek-devel installed. There is a good chance that the VMWare kernel module is not compatible with such a recent kernel version, but the error message from the build should tell us whether that's the case. Can you post the exact error message here?

  • andreas.dijkman
    andreas.dijkman Member Posts: 83 Bronze Badge

    Isn't the package open-vm-tools better suited for OL7 and newer? We stopped using binary VMWare-tools after OL6, as the Open VM Tools came with the OS and are working nicely, without recompiling kernel-modules and stuff.