Forum Stats

  • 3,771,062 Users
  • 2,253,216 Discussions
  • 7,875,729 Comments

Discussions

Unable to load oracle's required packages for OL 6.7

Jhil
Jhil Member Posts: 3,176 Bronze Trophy

Hi Team,

I have to install 11204 on OEL 6.,7 (some testing purpose).

Unable to load oracle required packages by using YUM, Kindly help me to fix it.


[[email protected] yum.repos.d]# pwd

/etc/yum.repos.d

[[email protected] yum.repos.d]# ls -l

total 8

-rw-r--r--. 1 root root 4949 Nov 2 2021 public-yum-ol6.repo.bkp


[[email protected] yum.repos.d]# wget http://public-yum.oracle.com/public-yum-el6.repo

--2021-11-02 00:32:21--  http://public-yum.oracle.com/public-yum-el6.repo

Resolving public-yum.oracle.com... 23.52.164.163, 2600:1408:5400:287::2a7d, 2600:1408:5400:2a5::2a7d

Connecting to public-yum.oracle.com|23.52.164.163|:80... connected.

HTTP request sent, awaiting response... 301 Moved Permanently

Location: https://public-yum.oracle.com/public-yum-el6.repo [following]

--2021-11-02 00:32:22--  https://public-yum.oracle.com/public-yum-el6.repo

Connecting to public-yum.oracle.com|23.52.164.163|:443... connected.

HTTP request sent, awaiting response... 404 Not Found

2021-11-02 00:32:24 ERROR 404: Not Found.


O.S Distro is OL 6.7


Regards,

Jhil

Answers

  • andreas.dijkman
    andreas.dijkman Member Posts: 83 Bronze Badge

    I don't think the OL6-repositories have changed in the last 5 years, as long as you have ol6_latest in there you should be good to go.

    What repository do you need because it looks like they are still available, just not the repo-file.

  • Jhil
    Jhil Member Posts: 3,176 Bronze Trophy

    Hi Anderson,

    I am trying to install oracle 11g on OL 6.7 , so that some packages must be loaded by using yum tool.


    Below commands should work

    1)  yum -y install oracle-validated

    2) yum install oracle-rdbms-server-11gR2-preinstall

    Kindly help me to install above 2 commands.

    Thanks for your reply.


    Regards,

    Jhil

  • andreas.dijkman
    andreas.dijkman Member Posts: 83 Bronze Badge

    Move the file public-yum-ol6.repo.bkp back in place so it is named public-yum-ol6.repo and do the yum install after that (directory /etc/yum.repos.d). You don't need the package oracle-validated because oracle-rdbms-server-11gR2-preinstall has replaced it.

  • Jhil
    Jhil Member Posts: 3,176 Bronze Trophy

    Hi Anderson,

    I am getting an error. Kindly look at the error once.

    [[email protected] yum.repos.d]# pwd

    /etc/yum.repos.d

    [[email protected] yum.repos.d]# ls -l

    total 8

    -rw-r--r--. 1 root root 4949 Nov 2 2021 public-yum-ol6.repo

    [[email protected] yum.repos.d]# 

    Trying to install oracle 11g preinstall packages (but facing an error)


    [[email protected] yum.repos.d]# yum install oracle-rdbms-server-11gR2-preinstall

    Loaded plugins: refresh-packagekit, security, ulninfo

    Setting up Install Process

    http://public-yum.oracle.com/repo/OracleLinux/OL6/UEKR3/latest/x86_64/repodata/repomd.xml: [Errno 14] problem making ssl connection

    Trying other mirror.

    Error: Cannot retrieve repository metadata (repomd.xml) for repository: public_ol6_UEKR3_latest. Please verify its path and try again

    ---------------------------------------------------------------------------------

    Internet is working on this server

    [[email protected] yum.repos.d]# ping google.com

    PING google.com (142.250.64.110) 56(84) bytes of data.

    64 bytes from lga34s31-in-f14.1e100.net (142.250.64.110): icmp_seq=1 ttl=128 time=306 ms

    ^C

    --- google.com ping statistics ---

    2 packets transmitted, 1 received, 50% packet loss, time 1245ms

    rtt min/avg/max/mdev = 306.921/306.921/306.921/0.000 ms



    Thank you Anderson,

  • andreas.dijkman
    andreas.dijkman Member Posts: 83 Bronze Badge

    It look's like OL6.7 is too old to communicate with modern https-servers. You might have luck updating to OL6.11 but I would just abandon OL6 all together, it is rather antiquated. Oracle 11.2.0.4 is also supported on OL7, so If you really need Oracle 11.2, migrate to a newer OS or use DVD-images (if they are still available...) to do package-installs.