Forum Stats

  • 3,814,410 Users
  • 2,258,870 Discussions
  • 7,892,703 Comments

Discussions

The JCA Binding Component was unable to establish an outbound JCA CCI connection due to the followin

User_PT1X6
User_PT1X6 Member Posts: 1 Green Ribbon

BINDING.JCA-12511

JCA Binding Component connection issue.

JCA Binding Component is unable to create an outbound JCA (CCI) connection


The JCA Binding Component was unable to establish an outbound JCA CCI connection due to the following issue: BINDING.JCA-12510

JCA Resource Adapter location error.

Unable to locate the JCA Resource Adapter via .jca binding file element <connection-factory/>

The JCA Binding Component is unable to startup the Resource Adapter specified in the <connection-factory/> element: location='eis/Db/SoaTest'.

The reason for this is most likely that either

 1) the Resource Adapters RAR file has not been deployed successfully to the WebLogic Application server or

 2) the '<jndi-name>' element in weblogic-ra.xml has not been set to eis/Db/SoaTest. In the last case you will have to add a new WebLogic JCA connection factory (deploy a RAR).

Please correct this and then restart the Application Server

I have used Data Source Name - SoaPractice

Datasource JNDI - jdbc/SoaPractice

Outbound connection pool JNDI - eis/Db/SoaTest

I have followed below steps to check the issue

1.checked and verified Test Data source in soa_server1 & 2 - got successful

2.Verified JNDI (eis/Db/SoaTest) and Data Source JNDI (jdbc/SoaPractice) and Datasource jndi is pointing to xaDataSource

3.Updated Db adapter after all changes are done.

But, Still i am getting same error

Is there any thing i need to do , can any one let me know?