Forum Stats

  • 3,815,254 Users
  • 2,258,986 Discussions
  • 7,893,015 Comments

Discussions

Unable to create a NAT Gateway

User_RBGL6
User_RBGL6 Member Posts: 1 Green Ribbon

"NAT gateway limit per VCN reached"

under VCN Nat Gateways shows (0)

Answers

  • User_TSFSO
    User_TSFSO Member Posts: 2 Green Ribbon

    Is there any resolution to this? I have the same problem. Never created a NAT gateway in the account before, so I'm not sure how I would have hit the limit.

    There is an Internet Gateway, but I want to turn that off once the NAT gateway is running. I tried deleting the Internet Gateway and then creating a NAT gateway, but it still gave me the error message.

    Marge Lynum-Oracle
  • User_TSFSO
    User_TSFSO Member Posts: 2 Green Ribbon


    Has anyone found a solution to this? I get the same error. Currently, I'm running everything with the 'Always Free' tier. I have not created a single NAT gateway, so I don't see how I could hit the limit.

    I have only one VCN too.

    Marge Lynum-Oracle
  • User_7IE4N
    User_7IE4N Member Posts: 1 Green Ribbon

    I was facing the same issue. It seems you are using the free tier of the OCI, which doesn't include NAT Gateways.

    To double-check, you can verify the Limits, Quotas and Services for your account. To do so, in the OCI console go to Cloud & "Governance & Administration", "Limits, Quotas and Usage". Then, in Service, choose "Virtual Cloud Network" and for Scope, select your region. If you are using the free tier, the Service Limit for NAT Gateway will be 0.

    If you want to enable instances from a private subnet to access the internet, while keeping the free tier, you should go with a NAT instance. This document shows how to implement a NAT instance: https://docs.oracle.com/en-us/iaas/Content/Resources/Assets/whitepapers/nat-instance-configuration.pdf

    Hope it helps.


    EN