Forum Stats

  • 3,853,618 Users
  • 2,264,246 Discussions
  • 7,905,417 Comments

Discussions

Unable to create a NAT Gateway

User_RBGL6
User_RBGL6 Member Posts: 1 Green Ribbon

"NAT gateway limit per VCN reached"

under VCN Nat Gateways shows (0)

Answers

  • User_TSFSO
    User_TSFSO Member Posts: 2 Green Ribbon

    Is there any resolution to this? I have the same problem. Never created a NAT gateway in the account before, so I'm not sure how I would have hit the limit.

    There is an Internet Gateway, but I want to turn that off once the NAT gateway is running. I tried deleting the Internet Gateway and then creating a NAT gateway, but it still gave me the error message.

    Marge Lynum-Oracle
  • User_TSFSO
    User_TSFSO Member Posts: 2 Green Ribbon


    Has anyone found a solution to this? I get the same error. Currently, I'm running everything with the 'Always Free' tier. I have not created a single NAT gateway, so I don't see how I could hit the limit.

    I have only one VCN too.

    Marge Lynum-Oracle
  • User_7IE4N
    User_7IE4N Member Posts: 1 Green Ribbon

    I was facing the same issue. It seems you are using the free tier of the OCI, which doesn't include NAT Gateways.

    To double-check, you can verify the Limits, Quotas and Services for your account. To do so, in the OCI console go to Cloud & "Governance & Administration", "Limits, Quotas and Usage". Then, in Service, choose "Virtual Cloud Network" and for Scope, select your region. If you are using the free tier, the Service Limit for NAT Gateway will be 0.

    If you want to enable instances from a private subnet to access the internet, while keeping the free tier, you should go with a NAT instance. This document shows how to implement a NAT instance: https://docs.oracle.com/en-us/iaas/Content/Resources/Assets/whitepapers/nat-instance-configuration.pdf

    Hope it helps.


    EN

  • starfry
    starfry Member Posts: 1 Green Ribbon

    This does not make sense, I have the same problem...

    I have a VCN, it has no nat gateway or service gateway in it.

    I cannot create a nat gateway or service gateway

    400-LimitExceeded, NAT gateway limit per VCN reached

    400-InvalidParameter, The maximum limit of 0 for Service gateway per VCN has been exceeded in VCN

    The reason for creating thise is specifically to support a bastion which is supposed to be supported in the free tier.

    I am using the terraform oci provider to create resources, however the same error occurs if I try to use the gui.

    Also, I in the "Limits, Quotas and Usage" screen I can see the NAT Gateway service limit is zero but I cannot find the Service Gateway limit anywhere.

    Could it also be confirmed that a NAT and/or Service Gateway created in the first thirty days will remain available and usabe after the first thirty days as long as they are not deleted. This is the behaviour that I saw - I only got the problem because I tore down and tried to redeploy resources.

    There is definitiely some inconsistencies between what is advertised as being available in the free tier (i.e. Bastion) and what is actually usable in the free tier. If there is a way to use Bastion in the free tier without NAT and/or Service gateways please advise.