Forum Stats

  • 3,876,239 Users
  • 2,267,082 Discussions
  • 7,912,477 Comments

Discussions

OBIEE 12c Sample Appliance v607 - Error on starting BI Services in Oracle VM VirtualBox

Hi,

I have installed the Oracle VM Virtual Box on my laptop and have imported the OBIEE 12c Sample Appliance V607 onto it (SampleAppv607p-appliance).

I have then started the appliance on the VM then selected Start -> Start DB & BI on the VM desktop, but whilst the database starts successfully, the BI Services fail. The relevant section of messages that are displayed in the terminal are shown below (involving the Node Manager).

I found something on the internet that said a person having exactly the same problem resolved it by "correcting the server time".

I'm not sure the steps they followed, or what to change the server time to (a specific time-zone or the time-zone of the host machine) but when I try to change the time on the VM desktop running the sample appliance it doesn't make any difference to the issue (the time displayed in the top right of the screen doesn't change despite the change of time zone and/or location).

Note that the VM time-zone is displayed as New York and my host laptop is in the UK on London time.

Any assistance or knowledge regarding this issue will be much appreciated.

The error:

Where the time is shown on the VM:

..but is also shown by selecting System -> Administration -> Date & Time, but changing the time zone there or by adding and setting a new Location in the right hand panel doesn't change the displayed time in the top right of the screen:

Regards,

Gavin

Tagged:

Best Answers

«1

Answers

  • Gianni Ceresa
    Gianni Ceresa Managing Director | Oracle ACE Director Member Posts: 6,731 Blue Diamond

    Hi Gavin,

    Somebody else posted this exact issue only a week or 2 ago.

    The time zone doesn't matter at all (except if you can use that as argument to have your company paying you a holiday to New York? Not sure it will really work 😁), but you are on the right thing looking at the date.

    The VM is very old (more than 5 years), and the OBIEE 12.2.1.1.0 contained has been installed before to distribute the VM. Because of that, the embedded SSL certificate are also more than 5 years old. And they are expired because of that.

    What you can do is, before to try to start the BI stack, to change the date of your virtual machine to take it back in time. Set a date in 2017 or 2018, disable automatically updating the date&time of the VM from internet (NTP) and also to not set it based on the date&time of the host (your laptop).

    Once the OS of the VM thinks it's really 2017 or 2018, you can start the product without problems.

    tri_pastra
  • Gavin 42
    Gavin 42 Member Posts: 9 Green Ribbon

    Hi Gianni,

    Thanks for your reply - much appreciated.

    I've tried setting the date back to 2017, after unticking the "Synchronize date and time over the network" setting, but the date / time keeps reverting back to what it was shortly afterwards. I don't think it's picking up the date / time from my laptop as the VM is New York time but my host laptop is UK time.

    So I'm not sure what I'm doing wrong? Here's the steps taken:

    First use the System -> Administration -> Date & Time option:

    Then untick Synchronize date and time over the network, then select a year of 2017:

    The date displayed in the right hand panel shows the 2017 date just chosen:

    ...but within seconds, the top date reverts back to what it was:

    ....shortly followed by the date underneath it in the calendar:

    So I tried changing the date by right clicking on the date shown there, and selecting Preferences:

    Select Time Settings in pop-up displayed:

    Then change the year to 2017, then click on Set System Time:

    The chosen date is correctly displayed in the top date (and is also correct in the calendar if you minimise and then display again - not shown on this screenshot) but......

    ....within seconds the date has reverted back to what is was again:

    So are there some other settings that need disabling to stop the changed date reverting back to what it was, or is this the incorrect method of changing the date on the VM?

    Thanks for your help.

    Regards,

    Gavin

  • Gianni Ceresa
    Gianni Ceresa Managing Director | Oracle ACE Director Member Posts: 6,731 Blue Diamond
    Answer ✓

    The other user who had the issue (it's in a MOSC forum) said he did execute this:

    VBoxManage setextradata "SampleAppv607p-appliance" "VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled" 1
    

    You can read a bit about a user having the same behavior you are reporting (the date switching back to the current one) and how that command fixed it.

    It's something to do, in theory, with the VM stopped.

    tri_pastraUser_H0R8F
  • Gavin 42
    Gavin 42 Member Posts: 9 Green Ribbon

    That's awesome - the changed VM date is now staying changed and the BI Services are on their way to being loaded in the VM.

    Thanks so much for your help - you've made my weekend :)

    Take care,

    Gavin

    tri_pastra
  • tri_pastra
    tri_pastra Member Posts: 15 Green Ribbon

    Do you have access to the Internet via the SampleAppv607p after you have changed the time configurations? Because I haven't and I need access to run some updates through the terminal 


    Best regards, 

    Pascal

  • Gianni Ceresa
    Gianni Ceresa Managing Director | Oracle ACE Director Member Posts: 6,731 Blue Diamond
    edited Feb 9, 2022 4:31PM

    The connection isn't technically impacted, but what makes your OBIEE work is what makes almost any existing online resource not work: if you try to act like being 5 years ago, most sites or resources using SSL will have certificates that aren't valid (because too recent).

    You can turn on the date/time synchronization with an NTP server, have your instance back to "today" and run your updates or other things. And then turn it off again and go back in time to be able to use OBIEE.

    Just keep in mind you shouldn't use this VM for anything else than looking at some example. You can easily install your own environment in a VM if needed (or just running it in containers so you can have all the 12c + OAS versions easily accessible.

  • dataviz-Oracle
    dataviz-Oracle Member Posts: 13 Employee
    Answer ✓

    we have put together the following doc that will workaround/solve the issue described above. Also can you please confirm where the image was downloaded from?


    User_H0R8F
  • User_C2EQM
    User_C2EQM Member Posts: 2 Green Ribbon

    I try the cmd method

    VBoxManage setextradata "SampleAppv607p-appliance" "VBoxInternal/Devices/0/Config/GetHostTimeDisabled" 1

    to be able to change the date in the VM for Obiee to start the node manger but now the VM wont start

    its giveing me this massage


    i hope you can help me with this

    best regards,,,


  • Gianni Ceresa
    Gianni Ceresa Managing Director | Oracle ACE Director Member Posts: 6,731 Blue Diamond

    Any reason you didn't follow the step provided in the PDF file above as they don't require to change the date of the VM?

    And if the VM doesn't work anymore, delete it and deploy a new one and back to the original state.