apps-infra

    Forum Stats

  • 3,873,766 Users
  • 2,266,638 Discussions
  • 7,911,626 Comments

Discussions

Discoverer 11.1.1.7 - getting Discoverer Plus (web) to work with MS Edge Browser

Alan Lawlor
Alan Lawlor Member Posts: 77 Bronze Badge
edited Feb 28, 2022 3:14PM in Discoverer

As many of you know, Microsoft is ending support for Internet Explorer in June 2022. At this point, it is the only browser compatible with Discoverer Plus as it launches Java

I have been exploring MS Edge feature for IE Mode (it works very well for older Oracle Forms), but cannot get it to work with Discoverer.

I have added my site to the IE Mode site list : myhost:myport/discoverer and it correctly shows the IE icon to the left of the address bar in Edge

However, when I either click on one of the saved connections or manually via "connect directly", the first redirect to myhost:myport/discoverer/app/directPartialConnect has dropped the IE icon (ie it is no longer in IE mode) and I get this error on the top of the screen:

"Oracle BI Discoverer Viewer cannot find the data necessary to display the results of this event. Correct any errors, and try again.

The application cannot find the required event parameter"

Has anyone else embarked down this road and got it to work ?

Or has anyone else taken a very different road to move off Internet Explorer prior to June 2022 ?

PS: Like many other companies, we have not yet got a budget/resources for the migration of thousands of reports to a new reporting tool or even OBI Foundation/ OBIEE

Many thanks in advance



Tagged:

Answers

  • Christian Berg-0racle
    Christian Berg-0racle Everything Analytics And Data Member Posts: 9,689 Gold Crown

    "PS: Like many other companies, we have not yet got a budget/resources for the migration of thousands of reports to a new reporting tool or even OBI Foundation/ OBIEE"

    With this you basically closed the door on me helping you since Disco even ended extended support back in 2017 :)

    You may want to remove the link to the GIF though as that actually points to your Discoverer environment

  • Alan Lawlor
    Alan Lawlor Member Posts: 77 Bronze Badge

    Thanks for your reply and the heads-up on the embedded link (edited)

    I am perfectly aware of the lack of support now on Discoverer, which is why I am posting on Communities, in the hope that someone else (other than Oracle who cannot provide support) may have found a workaround

    dtsmitsui
  • Alan Lawlor
    Alan Lawlor Member Posts: 77 Bronze Badge

    Yes I did : In addition to the Group policies and the IE site mode list, there is an additional group policy that needs to be set, because when you are logging in to Discoverer, the page performs a redirect to another address, and this causes Edge to "drop out" of "IE Mode"


    To resolve this, in the Local Group Policy Editor --> Computer Configuration --> Administrative Templates --> Microsoft Edge, ensure the following setting is enabled "Specify how in-page navigations to unconfigured sites behave when started from Internet Explorer mode pages"

apps-infra