Forum Stats

  • 3,825,929 Users
  • 2,260,581 Discussions
  • 7,896,738 Comments

Discussions

Trace kwqaexeckcur: Error = 604 during expdp

Hello,

I found the trace below in my oracle trace directoty.

When I export one table or more data I will get the same information.

The export data seems ok.

Other installations 19.14 has also this behavior in trace during export with expdp.

What could be the reason?

Thank you for help.



Trace file D:\ORACLE\diag\rdbms\test123\test123\trace\test123_ora_1110088.trc

Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production

Version 19.14.0.0.0

Build label:   RDBMS_19.14.0.0.0DBRU_WINDOWS.X64_211224.3

Windows NT Version V6.2 

ORACLE_HOME = D:\ORACLE\WINDOWS.X64_193000_db_home

Node name          : TESTSERVER

CPU                : 6 - type 86646 physical cores

Process Affinity   : 0x0000000000000000

Memory (Avail/Total): Ph:49232M/131071M, Ph+PgF:59012M/143802M

VM name            : VMWare Version (6)

Instance name: test123

Redo thread mounted by this instance: 1

Oracle process number: 163

Windows thread id: 1110088, image: ORACLE.EXE (SHAD)

 *** 2022-06-14T07:45:59.892336+02:00

*** SESSION ID:(158.29344) 2022-06-14T07:45:59.893328+02:00

*** CLIENT ID:() 2022-06-14T07:45:59.893328+02:00

*** SERVICE NAME:(TEST123) 2022-06-14T07:45:59.893328+02:00

*** MODULE NAME:(expdp.exe) 2022-06-14T07:45:59.893328+02:00

*** ACTION NAME:() 2022-06-14T07:45:59.893328+02:00

*** CLIENT DRIVER:() 2022-06-14T07:45:59.893328+02:00

 

kwqaexeckcur: Error = 604

kwqaexeckcur: Error = 604

 

Answers

  • Jason_(A_Non)
    Jason_(A_Non) Member Posts: 2,095 Silver Trophy

    Best guess (after finding only a few hits elsewhere) is to ensure your compatible parameter is set to 12.2 or higher. If that is not possible or doesn't resolve the issue, then Oracle support should be your next stop.

  • user6558325
    user6558325 Member Posts: 4 Blue Ribbon

    Thank you for feedback. The compatible parameter is set to 19.0.0

    SQL> show parameter compatible

    NAME                                TYPE       VALUE

    ------------------------------------ ----------- ------------------------------

    compatible                          string     19.0.0

    There is no error in the alert log. There is no refer to this trace in the alert log. Also no errors in the DataPump export log file.

  • User51642 Yong Huang
    User51642 Yong Huang Member Posts: 164 Bronze Badge
    edited Jun 23, 2022 2:56PM

    We have this message, too, whenever we run expdp. Function kwqaexeckcur seems to be related to events 10852 (Enable tracing for Enqueue Dequeue Operations) and 10853 (Enable tracing for Replicating AQ Operations). So I set them in PDB with "alter system set events '10852 trace name context forever, level 32'" and then 10853. I ran expdp again. The trace file just had one more message "kwqiclode queue is not replicated". I changed level from 32 to 16384 and tried again. Still the same. These levels are given in some Oracle notes. I could have tried other levels and see if some meaningful messages will be printed. (If you try it, remember to unset the event with "alter system ... context off" when you're done, or bounce instance.)

    I suggest opening an SR with Oracle Support. I'm guessing the response will be something like this message is informational only and can be ignored. But the meaning would still be interesting so insist on asking.

    (My database is 19c, directly installed i.e. not upgraded. Compatible parameter value is 19.0.0. Currently v$version shows 19.14.0.0.0.)

    [Update] Another idea. Error 604 is most likely the regular ora- facility error, so it means "error occurred at recursive SQL level %s". You can find the exact recursive SQL error by enabling SQL trace, e.g. "alter system set events '10046 trace name context forever, level 4'", then run expdp. Level 4 of 10046 trace allows you to see the runtime values of bind variables.