Could the sdo_util.get_coordinate()
function be renamed to something more intuitive? (or a new, documented, function created in its place)
The word "coordinate" seems misleading. Something like this might be better:
PointN()
Why does mdsys.st_geometry
have an PointN()
function, but sdo_geometry
doesn't?
Get_Vertex()
Would be consistent with the GetVertices()
function, but that function returns vertices as number columns in a table, not a point as a geometry. So in that sense, it might be misleading/confusing.
Or something like that
Worth considering?