Forum Stats

  • 3,838,561 Users
  • 2,262,383 Discussions
  • 7,900,687 Comments

Discussions

Is btrfs.mod missing from grub2-efi-x64-2.02-123.0.4?

User_9I3VF
User_9I3VF Member Posts: 2 Green Ribbon

I have an OL8 system with a btrfs rootfs. I ran a dnf upgrade this morning and on reboot I just got a grub> prompt. If I ran insmod btrfs I was told that btrfs.mod could not be found.

I booted off the UEK media and downgraded grub2 to 2.02-123.0.3 in a chroot shell. After this I could successfully boot the system.

Is the btrfs module missing in the 2.02-123.0.4 release or did my upgrade just have a hiccup?

Answers

  • User_9I3VF
    User_9I3VF Member Posts: 2 Green Ribbon

    I've double-checked this using strings and grep (I'm sure there's a proper tool to check) and the pre-built grubx64.efi from 123.0.3 has text in it implying btrfs support is built in, but the same file in 123.0.4 does not. I assume I could build my own efi file but then it won't be signed by Oracle and no good for secure boot.

    Is this just a build issue or has something changed in how OL8 supports btrfs for the root filesystem?