On January 27th, this site will be read-only as we migrate to Oracle Forums for an improved community experience. You will not be able to initiate activity until January 30th, when you will be able to use this site as normal.

    Forum Stats

  • 3,889,585 Users
  • 2,269,760 Discussions
  • 7,916,785 Comments

Discussions

Invoking Postgres Stored Procedure from Oracle SOA 11g

User_Q22IQ
User_Q22IQ Member Posts: 1 Green Ribbon

We are trying to connect to PostgreSQL DB from SOA and invoke the Postgres Stored Procedure.

While creating DB adapter in JDeveloper we are getting below error popup.


We tried creating DB adapters and connections with below methods:


  1. We tried creating DB adapter through similar Oracle converted Stored Procedure and Postgres Data Source connection , we got Platform class not supported exception. Platform class used for postgres connections as of now is - oracle.toplink.platform.database.DatabasePlatform
  2. Have gone through few blogs to overcome the issue and replaced the platform class with - org.eclipse.persistence.platform.database.PostgreSQLPlatform. But still see the above issue.
  3. Later replaced the platform class with Oracle platform class - org.eclipse.persistence.platform.database.Oracle10Platform . which is now giving below issue.

java.lang.ClassCastException: weblogic.jdbc.wrapper.JTSConnection_org_postgresql_jdbc_PgConnection cannot be cast to oracle.jdbc.OracleConnection

Later we tried disabling Wrap Data Types option in the Advanced settings of Postgres Data source in WebLogic console and still got the same error.


Could you please help us resolving the issue and suggest the path forward for rightly configuring Postgres DB adapter for invoking a Postgres Data Source.

Comments