Forum Stats

  • 3,838,563 Users
  • 2,262,383 Discussions
  • 7,900,687 Comments

Discussions

Trouble installing Oracle Linux 8 security advisories. Help!

User_AHF11
User_AHF11 Member Posts: 1 Green Ribbon

Hello,

I'm having trouble getting security advisories to install on an Oracle Linux 8.6 system.

Here are the steps I'm following and their results.

STEP1: sudo dnf updateinfo --sec-severity Important list

output:

ELSA-2021-1983 Important/Sec. python3-qrcode-5.1-12.module+el8.3.0+7868+2151076c.noarch

ELSA-2021-1983 Important/Sec. python3-qrcode-core-5.1-12.module+el8.3.0+7868+2151076c.noarch

STEP 2: dnf update --advisory ELEA-2022-1983

output:

Last metadata expiration check: 2:08:16 ago on Wed 03 Aug 2022 04:49:39 PM EDT.

Dependencies resolved.

Nothing to do.

Complete!

verbose option for STEP2: dnf update --advisory ELEA-2022-1983 -v

output:

Loaded plugins: builddep, changelog, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, groups-manager, needs-restarting, playground, repoclosure, repodiff, repograph, repomanage, reposync, ulninfo

DNF version: 4.7.0

cachedir: /var/cache/dnf

User-Agent: constructed: 'libdnf (Oracle Linux Server 8.6; server; Linux.x86_64)'

repo: using cache for: ol8_baseos_latest

ol8_baseos_latest: using metadata from Tue 02 Aug 2022 10:23:49 PM EDT.

repo: using cache for: ol8_appstream

ol8_appstream: using metadata from Tue 02 Aug 2022 10:30:00 PM EDT.

repo: using cache for: ol8_UEKR6

ol8_UEKR6: using metadata from Tue 19 Jul 2022 01:23:40 PM EDT.

Last metadata expiration check: 2:14:05 ago on Wed 03 Aug 2022 04:49:39 PM EDT.

--> Starting dependency resolution

--> Finished dependency resolution

Dependencies resolved.

Nothing to do.

Complete!

..

I have many security advisories listed and I cannot install any of them.

One thing I've discovered is that the file (python3-qrcode-5.1-12.module+el8.3.0+7868+2151076c.noarch), which is an updated version of the python3-qrcodre package is not available in any of my repos. Look at the output of these commands:

Command 1: dnf search --enablerepo=* python3-qrcode-core-5.1-12.module+el8.3.0+7868+2151076c.noarch

output:

No matches found.

Command 2: dnf repoquery python3-qrcode-core --enablerepo=*

output:

python3-qrcode-core-0:5.1-11.module+el8+5193+804ea283.noarch

python3-qrcode-core-0:5.1-12.module+el8.1.0+5408+7a7203ac.noarch

python3-qrcode-core-0:5.1-12.module+el8.2.0+5597+a171068f.noarch

python3-qrcode-core-0:5.1-12.module+el8.3.0+7867+49938b5b.noarch

.

NOTE:

This all started when I noticed that BigFix Security fixlets were failing. Under the hood BigFix is also running dnf commands. Here's the log:

[Tue Aug 2 11:31:02 EDT 2022] Install python3-qrcode-core-5.1-12.module+el8.3.0+7868+2151076c.noarch :

[Tue Aug 2 11:31:04 EDT 2022] 20467001 Install Failure: dnf -y install python3-qrcode-core-5.1-12.module+el8.3.0+7868+2151076c.noarch - Error:

[Tue Aug 2 11:31:04 EDT 2022] 20467001 ____ Last metadata expiration check: 1:13:01 ago on Tue 02 Aug 2022 10:18:02 AM EDT.

All matches were filtered out by modular filtering for argument: python3-qrcode-core-5.1-12.module+el8.3.0+7868+2151076c.noarch

Error: Unable to find a match: python3-qrcode-core-5.1-12.module+el8.3.0+7868+2151076c.noarch

I've been scouring (that's actually an understatement) the internet for a way to resolve this.

Any assistance is greatly appreciated!