Forum Stats

  • 3,874,178 Users
  • 2,266,677 Discussions
  • 7,911,757 Comments

Discussions

Oracle 11gR2 Warehouse Builder Design Center "Could Not Find Java Virtual Machine"

User_VQIAK
User_VQIAK Member Posts: 1 Green Ribbon

I'm having an issue with Oracle 11g R2 Design Center feature. When I click it, it gives me the error below:

C:\app[username]\product\11.2.0\dbhome_1\owb\bin\win32>call setowbenv.bat WARNING: Unknown directive: SetSkipJ2SDKCheck WARNING: Could not find jvm.cfg! in 'C:\app[username]\product\11.2.0\dbhome_1\jdk\jre\lib\jvm.cfg' WARNING: Cannot find default VM "client" at C:\app[username]\product\11.2.0\dbhome_1\jdk ERROR: Cannot find VM at: C:\app\[username]\product\11.2.0\dbhome_1\jdk Aborting!

I've tried many things to resolve this, as listed below:

  1. Download 32b version of JDK (actually, I've downloaded multiple to rule out the version issue, both 32 and 64)
  2. Point environment variable and path to JDK installation
  3. Change sqldeveloper.cfg file to include SetJavaHome {path to JDK}
  4. Move the jvm.cfg file to the directory it's expected to be at
  5. Checked the paths to ensure the expected files were there

With step 4, after doing so I receive a different error message: "Client VM is unsupported"

With step 5, after doing so I realized the path to the executable was not in: C:\app\[username]\product\11.2.0\dbhome_1\jdk

But instead in: C:\app\[username]\product\11.2.0\dbhome_1\jdk\bin

So, from all of this I feel that if I can change the path the Oracle Design Center is using to the correct path, then this should resolve. Problem is, I'm unsure where to find this. Also, if it helps I believe the Design Center uses JDeveloper, since the error suggests to view the Oracle 9i JDeveloper Install Guide at jdev\install.html. I tried going to this link but I'm not sure if it exists anymore because it took me to Google. I chose the most relevant link but still, I did not find any information regarding this issue. If anyone can help I'd be very thankful, this has been running me in circles for 4 days now.

More Info: I'm currently working in VMWare on a Windows 10 OS