This site is currently read-only as we are migrating to Oracle Forums for an improved community experience. You will not be able to initiate activity until January 30th, when you will be able to use this site as normal.

    Forum Stats

  • 3,889,987 Users
  • 2,269,775 Discussions
  • 7,916,823 Comments

Discussions

curl#60 - "Peer's Certificate issuer is not recognized.

user1067512
user1067512 Member Posts: 3 Green Ribbon

When I try to install a package in Oracle versions 7, 8 I have the following error

Oracle Linux 7

failure: repodata/repomd.xml from ol7_UEKR6: [Errno 256] No more mirrors to try.

https://yum.oracle.com/repo/OracleLinux/OL7/UEKR6/x86_64/repodata/repomd.xml: [Errno 14] curl#60 - "Peer's Certificate issuer is not recognize

Oracle Linux 8

Oracle Linux 8 BaseOS Latest (x86_64)                                               0.0 B/s | 0 B  00:00

Errors during downloading metadata for repository 'ol8_baseos_latest':

  - Curl error (60): Peer certificate cannot be authenticated with given CA certificates for https://yum.oracle.com/repo/OracleLinux/OL8/baseos/latest/x86_64/repodata/repomd.xml [SSL certificate problem: unable to get local issuer certificate]

Error: Failed to download metadata for repo 'ol8_baseos_latest': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried


I tried deactivating the repositories, installing the certificates and deleting and cleaning the cache but nothing, if anyone knows how to solve it I appreciate the help

Tagged:

Best Answer

  • VolneiCP
    VolneiCP Member Posts: 38 Red Ribbon
    edited Sep 29, 2022 3:50PM Answer ✓

    Hi,

    This isn't correct, but it can help: If using 'dnf' edit the /etc/yum.conf file and add the line: sslverify=false. And try again.

    In the case of 'curl' you can try using the parameter: --insecure.

    Maybe it helps.

Answers