Forum Stats

  • 3,875,416 Users
  • 2,266,914 Discussions
  • 7,912,203 Comments

Discussions

13.5 Installation with small template applied problem

B Hall
B Hall Member Posts: 326 Bronze Badge
edited Oct 27, 2022 3:10PM in Enterprise Manager

I'm trying to install 13.5 on Oracle Linux Server release 7.9 with the small template applied to a 19.17 single instance database. Everything is in order up to the point where I tried to run the recommended EM Prerequisite kit, for which the documentation states:

WARNING:

If you plan to use a database instance that was created with a preconfigured Management Repository using the database templates offered by Oracle, then make sure you pass the following parameter while invoking the EM Prerequisite Kit.

-componentVariables repository:EXECUTE_CHECKS_NOSEED_DB_FOUND:false

I've done so with:

./em13500_linux64.bin EMPREREQ_KIT=true -J-Djava.io.tmpdir=/u01/software/em13c/stage/ -componentVariables repository:EXECUTE_CHECKS_NOSEED_DB_FOUND:false

This returns:

 repository:EXECUTE_CHECKS_NOSEED_DB_FOUND:false

Invalid option(s): componentVariables

ERROR: Installer execution failed (1).


What should I actually use to make this work - or should I just skip this altogether?

Thanks, Bryan

Answers

  • B Hall
    B Hall Member Posts: 326 Bronze Badge

    If you leave that out - it will load and let you continue. However after entering the database info, you then get this nice mess and cannot continue:

    Extracting the installer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

    Checking monitor: must be configured to display at least 256 colors.  Actual 16777216   Passed

    Checking swap space: must be greater than 512 MB.  Actual 14335 MB   Passed

    Checking if this platform requires a 64-bit JVM.  Actual 64   Passed (64-bit not required)

    Preparing to launch the Oracle Universal Installer from /u01/software/em13c/stage/OraInstall2022-10-26_03-31-27PM

    Running EMPREREQ_KIT.

    ScratchPathValue :/u01/software/em13c/stage/OraInstall2022-10-26_03-31-27PM

    Oct 26, 2022 3:32:14 PM org.apache.sshd.common.io.DefaultIoServiceFactoryFactory getIoServiceProvider

    INFO: No detected/configured IoServiceFactoryFactory using Nio2ServiceFactoryFactory

    java.sql.SQLSyntaxErrorException: ORA-00911: invalid character


           at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:509)

           at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:461)

           at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:1104)

           at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:550)

           at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:268)

           at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:655)

           at oracle.jdbc.driver.T4CStatement.doOall8(T4CStatement.java:229)

           at oracle.jdbc.driver.T4CStatement.doOall8(T4CStatement.java:41)

           at oracle.jdbc.driver.T4CStatement.executeForRows(T4CStatement.java:928)

           at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1205)

           at oracle.jdbc.driver.OracleStatement.executeInternal(OracleStatement.java:1823)

           at oracle.jdbc.driver.OracleStatement.execute(OracleStatement.java:1778)

           at oracle.jdbc.driver.OracleStatementWrapper.execute(OracleStatementWrapper.java:303)

           at oracle.sysman.install.oneclick.queries.DBConnect.executeDDL(DBConnect.java:154)

           at oracle.sysman.install.oneclick.queries.executeSql.performQuery(executeSql.java:83)

           at oracle.sysman.install.oneclick.EMGCInputValidation.validate(EMGCInputValidation.java:2547)

           at oracle.sysman.install.oneclick.EMGCDatabaseConnectionDlgonNext.actionsOnClickofNext2(EMGCDatabaseConnectionDlgonNext.java:643)

           at oracle.sysman.install.oneclick.EMGCDatabaseConnectionDlgonNext$1.run(EMGCDatabaseConnectionDlgonNext.java:142)

    Caused by: Error : 911, Position : 32, Sql = alter user SYSMAN identified by %SYSMAN_PASSWORD%, OriginalSql = alter user SYSMAN identified by %SYSMAN_PASSWORD%, Error Msg = ORA-00911: invalid character


           at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:513)

           ... 17 more

    Unable to copy the logs to the permanent location: The permanent log directory is unknown (null)..

  • User_OE1DT
    User_OE1DT Member Posts: 2 Blue Ribbon
    edited Nov 4, 2022 2:45PM

    So, I am in this exact same situation, trying to install Enterprise Manager 13.5 - new installation, new DB built from template and hitting the ORA-00911. How do I get past this, or as the first user previously asked, do I have to just skip the prerequisite checking?

  • User_OE1DT
    User_OE1DT Member Posts: 2 Blue Ribbon

    Gave up on running buggy precheck and went ahead and ran the install and it worked fine.

    B Hall
  • B Hall
    B Hall Member Posts: 326 Bronze Badge

    Sorry I missed your post Friday. Glad you forged ahead.

    Support had me skip the prereq's as you found, and then leave out the flag for the template and it worked mostly fine. Mostly in that at step 8, at least with some X-Window servers you have to hit Next right away or you get a do-nothing spinning dialog box.

    While I'm impressed with what Oracle has done with upgrades for the database, OEM needs serious attention in documentation and installation code.