Forum Stats

  • 3,875,396 Users
  • 2,266,910 Discussions
  • 7,912,192 Comments

Discussions

Unable to install Oracle Linux 8.6 alongside Windows 11 (new computer)

mathguy
mathguy Member Posts: 10,912 Black Diamond

NOTE: Before I start, I should clarify that I am aware of other options (including WSL, virtual machine, and even dropping Win 11 altogether and installing just Linux). I am not asking about workarounds, I am asking about solving the issue head on.

= = = = = =

My old computer is a Dell desktop which came with Win 10. I had no trouble installing Oracle Linux 7.5 next to it, for dual boot - I have been working on that machine for several years.

I just got a new Dell desktop, preloaded with Win 11. I thought it would be relatively simple to install Oracle Linux 8.6 alongside it, for dual boot. Wishful thinking!

First I made room for Linux on the hard disk. That was no problem. Then I created a full boot/install image on a USB drive (same as I did a few years ago for the older version). I tried two different ways - one was to download the ISO from the Oracle web site and burn it on the USB drive using the instructions from Oracle, on the old machine using Linux (dd command). The other was to download the ISO on the new machine, under Windows, and create the bootable image on USB using Rufus. In both cases the process (detailed below) hangs in exactly the same way and at the same point - so the problem likely lies elsewhere. I am almost certain the image is good - I suspect problems with UEFI and whatnot on the new machine. (Just for kicks, I tried booting the old computer from the same USB drive - that worked without problems. I am able to start a Linux installation from it - I just don't need that on the old computer.)

So - from Windows, I am able to restart the machine with "advanced boot options" or whatever Windows calls it, I select the USB for booting, and I get the first screen with three choices: Install Oracle Linux 8.6, Try and Install ...., and whatever the third option is (probably "start Windows").

I select Install Oracle Linux 8.6 - or Try and Install, I get the same behavior in both cases. At this point, the booting process hangs right away: I get a completely dark screen, with just what looks like a prompt - a single underscore in the top-left corner, not blinking.

The firmware interface is UEFI, and the hard disk uses GUID partition table. Using Rufus, I was asked about these options, and I selected the correct ones. Still, I suspect I am doing something wrong (or I didn't understand something), but I can't figure out what.

Any thoughts? Any info I can add?

Thank you - mathguy

Comments

  • user10174131
    user10174131 Member Posts: 48 Blue Ribbon

    I haven't tried it, but this appears to be the easiest way to get both of these OS environments installed.

    Easily run Oracle Linux on your Windows Desktop

    Since you mentioned that you have no interest in the WSL, that probably won't work for you, but you might try it out.

    Windows probably shouldn't have anything to do with your Linux install, so can you configure your BIOS/UEFI to boot the iso directly? And can you easily rebuild this PC if you accidentally write to the wrong partition?

  • mathguy
    mathguy Member Posts: 10,912 Black Diamond

    I read a bit more - I think I need to learn about Secure Boot.

    Apparently with Windows 11, Microsoft requires manufacturers (like Dell) to install UEFI with Secure Boot - which gets in the way of installing other OS's. Not sure if disabling Secure Boot is even possible; but I think it is very likely that if I disable SB, then Windows will not boot anymore (which defeats the purpose of the whole exercise).

    If this is indeed the issue, I wonder why Oracle's installation instructions don't say anything about it. It has nothing to do with another OS on the machine - it's about installing OL on a machine with UEFI with Secure Boot.

    From what I am reading, Ubuntu and Fedora may support Secure Boot out of the box, but RH/Oracle Linux does not. I may need to learn about Secure Boot to see if there's something I need to do manually - to "add" OL to the Secure Boot table of "safe entities" or whatever the terminology may be.

    @user10174131 - The OS (Windows) has something to do with it, only in the sense that MS made some requirements regarding UEFI - either you enforce Secure Boot or the systems you sell are not "Windows - certified".

    As to WSL - that is an option, but there are reasons to want a Linux system that makes its own system calls, not translated into Windows system calls. There are other differences too; for example in Linux I can compile assembler code in 32-bit mode (don't ask why I care about that); Windows supports Linux, but that version of Linux can't do anything in 32-bit mode.

    At some point I may in fact want to get rid of Windows altogether. I am not sure it will be easy to keep all the data I create in WSL if I do that. For example, I don't know what file system Windows uses for WSL files, and I don't want to find out after the fact that what I thought can be done can't, in reality, be done.

    In any case - my question in this thread is only about installing OL 8.6 alongside Win for dual boot, not about any other options.

    Thank you!

  • user10174131
    user10174131 Member Posts: 48 Blue Ribbon

    I have definitely run upstream RH9 in secure boot mode, so that particular version is capable. Getting dual boot running with that would be a great challenge.

    My temptation would be to downgrade to BIOS boot, then see if Windows still runs. Assuming so, that is probably easier to configure.