apps-infra

    Forum Stats

  • 3,874,066 Users
  • 2,266,672 Discussions
  • 7,911,720 Comments

Discussions

dyn_updater fails to start on Ubuntu 22.04

User_ACQ01
User_ACQ01 Member Posts: 1 Green Ribbon

When I launch dyn_updater, I get the following (see below).

I installed it from the download link on dyndns.org, following the instructions on the site.

Any advice?

Thanks,

-Eric.


[email protected]:/usr$ dyn_updater

Traceback (most recent call last):

 File "/ConsoleSetLibPath.py", line 38, in <module>

 File "/dyn_updater.py", line 131, in <module>

 File "/dyn_updater.py", line 45, in gui

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 1614, in _handle_fromlist

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 313, in _call_with_frames_removed

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 1565, in _find_and_load

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 1532, in _find_and_load_unlocked

 File "/lib/frontend/qt.py", line 27, in <module>

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 1565, in _find_and_load

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 1532, in _find_and_load_unlocked

 File "/lib/daemon/common.py", line 21, in <module>

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 1565, in _find_and_load

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 1532, in _find_and_load_unlocked

 File "/ctypes/__init__.py", line 7, in <module>

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 1565, in _find_and_load

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 1532, in _find_and_load_unlocked

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 584, in _check_name_wrapper

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 495, in set_package_wrapper

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 508, in set_loader_wrapper

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 1132, in load_module

 File "/usr/lib/python3.3/importlib/_bootstrap.py", line 313, in _call_with_frames_removed

ImportError: libffi.so.6: cannot open shared object file: No such file or directory

apps-infra