Forum Stats

  • 3,782,433 Users
  • 2,254,645 Discussions
  • 7,880,078 Comments

Discussions

Connection Timeout in Call of external Sync WS

521509
521509 Member Posts: 53
edited Dec 15, 2008 7:00AM in BPEL
Hi!

I have a asynchronous web service call (<invoke>) to an external web service.

So, I have trouble with connection timeout.
I add timeout property to partnerlink and set value of this property to 30 seconds.
But this property doesn't work, because the status of the instance after 30 seconds is active. I try to change timeout to 60 seconds, but it also doesn't work.

Anybody can help me??
Tagged:
«1

Comments

  • 521509
    521509 Member Posts: 53
    I also tried other way.... to create connection timeout.

    I added Scope activity. then I put Invoke activity into scope activity.

    then to scope activity I added onAlarm branch.

    So, this construction works. But it's not automatically. I need to "Refresh Alarm Table" in BPEL Console to stop active intstancies.

    Is there anyway to "Refresh Alarm Table" automatically???

    Thank You.

    P.S. Sorry for my English :)
  • 486186
    486186 Member Posts: 65
    Hi,
    Does anyone have another solution for this problem?
    I'm running 10.1.3.3.0 and this I think is unacceptable on a product such as this.
    Is there any working automatic workaround?


    Thanks,
    Alex
  • Buddy
    Buddy Member Posts: 33 Blue Ribbon
    Hi

    Hope the following links would be helpfull

    http://dietrichschroff.blogspot.com/2008/03/bpel-timeout-behaviour-of-synchronous.html
    http://soastuff.wordpress.com/2007/05/24/synchronous-bpel-processes-and-timeout-errors

    Thanks

    Buddhadev
  • 486186
    486186 Member Posts: 65
    Hi,
    The only problem on those 2 solutions is that they are intended to the Oracle Application Server.
    I'm running BPEL on weblogic 9.2, so the configuration files reference on those articles are not valid for my env.

    Thanks
    Alex
  • Arik
    Arik Member Posts: 904
    Alex,

    Must you wait for the WS to finish or you can continue with the process?

    Riko
  • 486186
    486186 Member Posts: 65
    Hi,
    it's a blocking sync call. :(
    thanks
  • 486186
    486186 Member Posts: 65
    Hi,
    I can't believe that nobody knows how to increase this parameter in a WL 9.2 / BPEL 10.1.3.3 installation.
    After all it's a official supported platform and yet, a standard configuration feature like this one is, apparently, forgotten by Oracle.

    On my project i have to invoke a external Sync Webservice with the timeout defined of 5min. I do not see any possible workaround for this problem.

    thanks,
    Alex
  • 662770
    662770 Member Posts: 6
    Alex, on BPEL console there on admin
    there is a parameter that's is call maxSyncWaitTime, there express the the time in second if you need to wait 5 minutes you must to define to 300, also check the parameter of time-out of transaction-manager.xml of the instance where BPEl is deploy

    Hope it helps
  • 486186
    486186 Member Posts: 65
    Hi,
    I already try to change the maxSyncWaitTime with no effect.
    The transaction-manager.xml from what i've been told is not used in the weblogic instalation.
  • 486186
    486186 Member Posts: 65
    Plus, the value on the file is set to:
    transaction-timeout="30"

    I'm getting timeouts around 120 secs.

    thanks,
This discussion has been closed.