Forum Stats

  • 3,853,837 Users
  • 2,264,281 Discussions
  • 7,905,463 Comments

Discussions

Getting NPE while adding Remote Portlets

User628988-Oracle
User628988-Oracle Member Posts: 11
edited Aug 5, 2008 12:56AM in WebLogic Portal
Hi,
I am working for BI Disco team, I have one WSRP producer . With this I am able to publish port lets properly in Oracle Portal 11g and WebSphere Portal 6.1, but same one is failing in Weblogic Portal 10.3 ( build date is 20080730 ) .

Remote Producers registration is successful, but when I am trying to add the remote portlet getting following Exception

java.lang.NullPointerException
at com.bea.jsptools.portal.helpers.wsrp.ProducerManagerControlImpl.addPortlet(ProducerManagerControlImpl.java:389)
at com.bea.jsptools.portal.helpers.wsrp.ProducerManagerControlBean.addPortlet(ProducerManagerControlBean.java:450)
at portalTools.definitions.portletProducers.portlets.BrowseController$AddAction.doAction(BrowseController.java:465)
at com.bea.portal.tools.portal.controls.PortalControlImpl.executeActions(PortalControlImpl.java:63)
at com.bea.portal.tools.portal.controls.PortalControlBean.executeActions(PortalControlBean.java:122)
at portalTools.definitions.portletProducers.portlets.BrowseController.addPortlets(BrowseController.java:321)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)

Comments

This discussion has been closed.