Forum Stats

  • 3,769,603 Users
  • 2,252,991 Discussions
  • 7,875,117 Comments

Discussions

Unable to start SOA suite

659086
659086 Member Posts: 47
edited Sep 15, 2008 5:58AM in SOA Suite Discusssions
Hi,

After my machine crashed I can not start SOA suite anymore.

Configuration information
Running in C:\oracle\product\10.1.3.1\OracleAS_1
Operation mode:Startup, App Server, No Enterprise Manager, Single Instance
-----
Oracle home:C:\oracle\product\10.1.3.1\OracleAS_1
Oracle home name:Unnamed
Instance name:as.VM-ORATEST.<domain>
Instance type:allProducts
Version:10.1.3.1.0
Uses infrastructure:false
Not an infrastructure instance, no infrastructure information available
Components:[j2ee, apache, orabpel, oraesb, owsm, Wsil]
-----
2008-09-12 11:31:37.830--Begin log output for Mid-tier services (as.VM-ORATEST.<domain>)
-----

2008-09-12 11:31:37.830--Processing Step: starting OPMN

2008-09-12 11:53:38.139--End log output for Mid-tier services (as.VM-ORATEST.<domain>)
-----
OPMN has thrown an unknown exception
oracle.appserver.startupconsole.model.ConsoleException: OPMN has thrown an unknown exception
at oracle.appserver.startupconsole.control.OPMNController.doStart(OPMNController.java:108)
at oracle.appserver.startupconsole.control.Controller.start(Controller.java:69)
at oracle.appserver.startupconsole.control.GroupController.doStart(GroupController.java:47)
at oracle.appserver.startupconsole.control.Controller.start(Controller.java:69)
at oracle.appserver.startupconsole.view.controller.ControllerAdapter.start(ControllerAdapter.java:30)
at oracle.appserver.startupconsole.view.controller.MasterControlAdapter.run(MasterControlAdapter.java:94)
at oracle.appserver.startupconsole.view.Runner.main(Runner.java:39)
Caused by: oracle.ias.opmn.optic.OpticBadRequestException: Error starting opmn server: 2
at oracle.ias.opmn.optic.OpmnAdmin.executeCommand(OpmnAdmin.java:147)
at oracle.ias.opmn.optic.OpmnAdmin.startOpmnServer(OpmnAdmin.java:77)
at oracle.appserver.startupconsole.control.OPMNController.doStart(OPMNController.java:90)
... 6 more
Exception caused by
Error starting opmn server: 2
oracle.ias.opmn.optic.OpticBadRequestException: Error starting opmn server: 2
at oracle.ias.opmn.optic.OpmnAdmin.executeCommand(OpmnAdmin.java:147)
at oracle.ias.opmn.optic.OpmnAdmin.startOpmnServer(OpmnAdmin.java:77)
at oracle.appserver.startupconsole.control.OPMNController.doStart(OPMNController.java:90)
at oracle.appserver.startupconsole.control.Controller.start(Controller.java:69)
at oracle.appserver.startupconsole.control.GroupController.doStart(GroupController.java:47)
at oracle.appserver.startupconsole.control.Controller.start(Controller.java:69)
at oracle.appserver.startupconsole.view.controller.ControllerAdapter.start(ControllerAdapter.java:30)
at oracle.appserver.startupconsole.view.controller.MasterControlAdapter.run(MasterControlAdapter.java:94)
at oracle.appserver.startupconsole.view.Runner.main(Runner.java:39)

Any clue?
Tagged:

Answers

  • 522026
    522026 Member Posts: 1,220
    Hi,
    can you please take a look at your opmn.xml file? I think something is broken there...
    Perhaps you can post it.
  • 659086
    659086 Member Posts: 47
    Here it is ...

    <?xml version = '1.0' encoding = 'UTF-8'?>
    <opmn xmlns="http://www.oracle.com/ias-instance">
    <log path="$ORACLE_HOME\opmn\logs\opmn.log" comp="internal;ons;pm" rotation-size="1500000"/>
    <debug path="$ORACLE_HOME\opmn\logs\opmn.dbg" comp="internal" rotation-size="1500000"/>
    <notification-server>
    <port local="6100" remote="6200" request="6003"/>
    <ssl enabled="true" wallet-file="$ORACLE_HOME\opmn\conf\ssl.wlt\default"/>
    </notification-server>
    <process-manager>
    <process-modules>
    <module path="$ORACLE_HOME\opmn\lib\libopmnohs">
    <module-id id="OHS"/>
    </module>
    <module path="$ORACLE_HOME\opmn\lib\libopmnoc4j">
    <module-id id="OC4J"/>
    </module>
    <module path="$ORACLE_HOME\opmn\lib\libopmncustom">
    <module-id id="CUSTOM"/>
    </module>
    <module path="$ORACLE_HOME\opmn\lib\libopmniaspt">
    <module-id id="IASPT"/>
    </module>
    </process-modules>
    <ias-instance id="as.VM-ORATEST.<domain>" name="as.VM-ORATEST.<domain>">
    <environment>
    <variable id="TMP" value="C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp"/>
    </environment>
    <module-data>
    <category id="start-parameters">
    <data id="routing-id" value="g_rt_id"/>
    </category>
    </module-data>
    <ias-component id="HTTP_Server">
    <process-type id="HTTP_Server" module-id="OHS">
    <environment>
    <variable id="PERL5LIB" value="C:\oracle\product\10.1.3.1\OracleAS_1\Apache\Apache\mod_perl\site\5.8.3\lib\MSWin32-x86-multi-thread;$ORACLE_HOME\perl\5.8.3\lib;$ORACLE_HOME\perl\site\5.8.3\lib"/>
    <variable id="PHPRC" value="C:\oracle\product\10.1.3.1\OracleAS_1\Apache\Apache\conf"/>
    <variable id="PATH" value="$ORACLE_HOME\Perl\5.8.3\bin\MSWin32-x86-multi-thread" append="true"/>
    </environment>
    <module-data>
    <category id="start-parameters">
    <data id="start-mode" value="ssl-enabled"/>
    </category>
    </module-data>
    <process-set id="HTTP_Server" numprocs="1"/>
    </process-type>
    </ias-component>
    <ias-component id="IASPT" status="disabled">
    <environment>
    <variable id="LD_LIBRARY_PATH" value="C:\oracle\product\10.1.3.1\OracleAS_1/lib" append="true"/>
    </environment>
    <process-type id="IASPT" module-id="IASPT" working-dir="C:\oracle\product\10.1.3.1\OracleAS_1/iaspt/bin">
    <port id="ajp" range="7501-7600"/>
    <process-set id="IASPT" numprocs="1"/>
    </process-type>
    </ias-component>
    <ias-component id="ASG" status="enabled" id-matching="true">
    <process-type id="ASG" module-id="CUSTOM">
    <environment>
    <variable id="OS" value="Windows_NT"/>
    </environment>
    <start timeout="600"/>
    <stop timeout="120"/>
    <process-set id="ASG" numprocs="1">
    <module-data>
    <category id="start-parameters">
    <data id="start-executable" value="C:\oracle\product\10.1.3.1\OracleAS_1\jdk\bin\java"/>
    <data id="start-args" value="-ms20m -Djava.library.path=C:\oracle\product\10.1.3.1\OracleAS_1\bin;C:\oracle\product\10.1.3.1\OracleAS_1\dsa\bin;C:\oracle\product\10.1.3.1\OracleAS_1\oui\lib\win32 -classpath C:\oracle\product\10.1.3.1\OracleAS_1\dsa\jlib;C:\oracle\product\10.1.3.1\OracleAS_1\dsa\jlib\duf.jar;C:\oracle\product\10.1.3.1\OracleAS_1\lib\dms.jar;C:\oracle\product\10.1.3.1\OracleAS_1\oui\jlib\OraInstaller.jar;C:\oracle\product\10.1.3.1\OracleAS_1\jlib\srvm.jar;C:\oracle\product\10.1.3.1\OracleAS_1\jlib\netcfg.jar;C:\oracle\product\10.1.3.1\OracleAS_1\lib\xmlparserv2.jar;C:\oracle\product\10.1.3.1\OracleAS_1\assistants\jlib\assistantsCommon.jar;C:\oracle\product\10.1.3.1\OracleAS_1\jdbc\lib\classes12.zip;C:\oracle\product\10.1.3.1\OracleAS_1\jdbc\lib\nls_charset12.zip;C:\oracle\product\10.1.3.1\OracleAS_1\jlib\share.jar;C:\oracle\product\10.1.3.1\OracleAS_1\opmn\lib\optic.jar;C:\oracle\product\10.1.3.1\OracleAS_1\j2ee\home\jazn.jar;C:\oracle\product\10.1.3.1\OracleAS_1\jlib\ldapjclnt10.jar oracle.duf.dufserver.DufServer C:\oracle\product\10.1.3.1\OracleAS_1\dsa\dsa.conf"/>
    </category>
    </module-data>
    </process-set>
    </process-type>
    </ias-component>
    <ias-component id="default_group">
    <process-type id="home" module-id="OC4J" status="enabled">
    <module-data>
    <category id="start-parameters">
    <data id="java-options" value="-Xrs -server -XX:MaxPermSize=128M -ms512M -mx1024M -XX:AppendRatio=3 -Djava.security.policy=$ORACLE_HOME/j2ee/home/config/java2.policy -Djava.awt.headless=true -Dhttp.webdir.enable=false"/>
    </category>
    <category id="stop-parameters">
    <data id="java-options" value="-Djava.security.policy=$ORACLE_HOME/j2ee/home/config/java2.policy -Djava.awt.headless=true -Dhttp.webdir.enable=false"/>
    </category>
    </module-data>
    <start timeout="600" retry="2"/>
    <stop timeout="120"/>
    <restart timeout="720" retry="2"/>
    <port id="default-web-site" range="12501-12600" protocol="ajp"/>
    <port id="rmi" range="12401-12500"/>
    <port id="rmis" range="12701-12800"/>
    <port id="jms" range="12601-12700"/>
    <process-set id="default_group" numprocs="1"/>
    </process-type>
    <process-type id="oc4j_soa" module-id="OC4J" status="enabled">
    <module-data>
    <category id="start-parameters">
    <data id="java-options" value="-Xrs -server -XX:MaxPermSize=128M -ms512M -mx1024M -XX:AppendRatio=3 -Djava.security.policy=$ORACLE_HOME/j2ee/oc4j_soa/config/java2.policy -Djava.awt.headless=true -Dhttp.webdir.enable=false -Doraesb.home=C:\oracle\product\10.1.3.1\OracleAS_1\integration\esb -Dhttp.proxySet=false -Doc4j.userThreads=true -Doracle.mdb.fastUndeploy=60 -Dorabpel.home=C:\oracle\product\10.1.3.1\OracleAS_1\bpel -Xbootclasspath^/p:C:\oracle\product\10.1.3.1\OracleAS_1\bpel/lib/orabpel-boot.jar -Dhttp.proxySet=false"/>
    </category>
    <category id="stop-parameters">
    <data id="java-options" value="-Djava.security.policy=$ORACLE_HOME/j2ee/oc4j_soa/config/java2.policy -Djava.awt.headless=true -Dhttp.webdir.enable=false"/>
    </category>
    </module-data>
    <start timeout="600" retry="2"/>
    <stop timeout="120"/>
    <restart timeout="720" retry="2"/>
    <port id="default-web-site" range="12501-12600" protocol="ajp"/>
    <port id="rmi" range="12401-12500"/>
    <port id="rmis" range="12701-12800"/>
    <port id="jms" range="12601-12700"/>
    <process-set id="default_group" numprocs="1"/>
    </process-type>
    </ias-component>
    </ias-instance>
    </process-manager>
    </opmn>
  • 522026
    522026 Member Posts: 1,220
    Hi,

    can you please remove in
    <ias-instance id="as.VM-ORATEST.<domain>" name="as.VM-ORATEST.<domain>">
    the <domain>?
    I think the "<" and ">" from domain could be the problem...
  • 659086
    659086 Member Posts: 47
    Hi,

    <domain> is actually correct.domain. I just change it not to reveal actual domain.

    brg
  • 522026
    522026 Member Posts: 1,220
    Hmmm...

    can you please try opmnctl start and not opmnctl startall?
    522026
  • 659086
    659086 Member Posts: 47
    Here are both: ....

    C:\oracle\product\10.1.3.1\OracleAS_1\opmn\bin>opmnctl startall
    opmnctl: starting opmn and all managed processes...
    pingwait exits with 2

    Timed out waiting for OPMN to initialize. OPMN may be down or
    taking a long time to initialize. Will not attempt to start
    processes because OPMN is unreachable. If OPMN is initializing,
    retrying the command may prove successful. If OPMN is down,
    correct the underlying problem before retrying the command.

    ------

    C:\oracle\product\10.1.3.1\OracleAS_1\opmn\bin>opmnctl start
    pingwait exits with 2
    opmnctl: opmn start failed
  • 659086
    659086 Member Posts: 47
    Hi,

    I found the solution of problem.

    there seems to be a bug and opmn/logs/opmn.log is huge.

    I just moved all files from log dir to e.g. old dir and start soa suite.

    brg
This discussion has been closed.