Forum Stats

  • 3,853,839 Users
  • 2,264,285 Discussions
  • 7,905,471 Comments

Discussions

NPE while registering Remote Portlet in Weblogic Portal 10.3

594872
594872 Member Posts: 21
edited Oct 8, 2008 9:56AM in WebLogic Portal
Hi,

I am on Weblogic Portal 10.3 and am trying to create a remote portlet in my portal application. The remote Portlet is hosted on OC4J 10.3.1.1.1 and is consumed properly on Oracle Portal without any errors, however, when I try to access the portlet's wsdl via the Remote Portlet Wizard, I get the following exception while registering.



bq. {color:#3366ff}!ENTRY com.bea.wlp.eclipse.common 1 1 2008-10-06 11:37:28.938{color} \\ {color:#3366ff} \\ !MESSAGE [Portal-ERROR|http://forums.oracle.com/forums/] There was a problem submitting registration for this producer.{color} \\ {color:#3366ff} \\ Reason = ProducerAgent::java.lang.NullPointerException: null{color} \\ {color:#3366ff} \\ !ENTRY com.bea.wlp.eclipse.common 4 4 2008-10-06 11:37:28.938{color} \\ {color:#3366ff} \\ !MESSAGE {color} \\ {color:#3366ff} \\ !STACK 0{color} \\ {color:#3366ff} \\ java.lang.NullPointerException{color} \\ {color:#3366ff} \\ at weblogic.utils.encoders.CharacterDecoder.decodeBuffer(CharacterDecoder.java:188){color} \\ {color:#3366ff} \\ at com.bea.wsrp.util.XmlUtils.decodeBASE64(XmlUtils.java:270){color} \\ {color:#3366ff} \\ at com.bea.wsrp.bind.RegistrationContextImpl.<init>(RegistrationContextImpl.java:44){color} \\ {color:#3366ff} \\ at com.bea.wsrp.client.ProducerAgentImpl.register(ProducerAgentImpl.java:258){color} \\ {color:#3366ff} \\ at com.bea.wsrp.client.ProducerAgentImpl.register(ProducerAgentImpl.java:221){color} \\ {color:#3366ff} \\ at com.bea.wlp.eclipse.wsrp.portletbuilder.wsrp.ProducerAgent.submitRegistrationDocument(ProducerAgent.java:384){color} \\ {color:#3366ff} \\ at com.bea.wlp.eclipse.wsrp.portletbuilder.wizard.wsrp.SelectProducerPanel$RegistrationRunner.run(SelectProducerPanel.java:1425){color} \\ {color:#3366ff} \\ !ENTRY com.bea.wlp.eclipse.common 1 1 2008-10-06 11:37:28.953{color} \\ {color:#3366ff} \\ !MESSAGE [Portal-DEBUG|http://forums.oracle.com/forums/] RegistrationPanel::could not submit registration document: null{color}

{color:#3366ff}
{color}


{color:#000000}This producer is fully WSRP compliant and works perfectly fine with Oracle Portal. Any pointers of where it might go wrong?{color}

Ansuman

Best Answer

Answers

This discussion has been closed.