Forum Stats

  • 3,770,751 Users
  • 2,253,162 Discussions
  • 7,875,575 Comments

Discussions

setting nonProxyHosts property not working

664113
664113 Member Posts: 2
edited Oct 9, 2008 9:34AM in JRockit
How do you set the nonProxyHosts property for Jrockit 1.5.0_11. We are trying to set this property for Aqualogic ESB which is using Jrockit by setting this property in net.properties under Jrockit but it does not seem to honor it. It seems to pick up proxyHost property though.
Tagged:

Answers

  • The properties described in this document: http://java.sun.com/javase/6/docs/technotes/guides/net/properties.html should all apply to JRockit in the same way. If they do not, please contact support or post a reproducer here.

    Thanks,
    /Staffan
    Staffan Larsen-Oracle
  • 664113
    664113 Member Posts: 2
    Well the issue is when I run the installSvc.cmd to install Aqualogic as a service and I am setting environment variable JAVA_OPTIONS with -DnonProxyHosts with a pipe (|) delimited list (e.g host1|host2|host3), but the script barfs and I think it does not like pipe symbol. May be this is more of a Aqualogic question than a JRockit one, or may be a windows script. Do you know if I need to escape the pipe symbol somehow? I tried escaping it with ^ but that did not help.
  • Yes, you are right: this is more of an Aqualogic or windows scripting question. But I think what you need to do is to surround the while -DnonProxyHosts expressions with quotation marks (").

    /staffan
This discussion has been closed.