Forum Stats

  • 3,855,199 Users
  • 2,264,473 Discussions
  • 7,905,928 Comments

Discussions

Exception in Clipper Portlet....!!!!!!!

664514
664514 Member Posts: 10
edited Oct 16, 2008 12:02PM in WebLogic Portal
I am trying to create a **clipper portlet** as given in the documentation of BEA

But when i try to run it I get the following exception
java.net.ConnectException: Tried all: '4' addresses, but could not connect over HTTP to server: 'www.google.com', port: '80'

at weblogic.net.http.HttpClient.openServer(HttpClient.java:365)

at weblogic.net.http.HttpClient.openServer(HttpClient.java:434)

at weblogic.net.http.HttpClient.<init>(HttpClient.java:159)

at weblogic.net.http.HttpClient.<init>(HttpClient.java:149)

at weblogic.net.http.HttpClient.New(HttpClient.java:269)

Truncated. see log file for complete stacktrace


Anyone having any idea regarding this ??

Answers

  • 648793
    648793 Member Posts: 96
    edited Oct 10, 2008 4:58PM
    You may have to add the protocol "http" in the URL of the clipper portlet. Just give it a try.
  • 664514
    664514 Member Posts: 10
    thanks Raajeev .
    But i have already given "http" in the url.
    The same url works for browser portlet but it does not work for clipper portlet.

    Is there any prerequisite for creating a clipper portlet??
    Or something which is not required for browser portlet and but essential for clipper portlet??
  • 655221
    655221 Member Posts: 116
    It works fine for me (I tried WLP 10.2): http://download-llnw.oracle.com/docs/cd/E13155_01/wlp/docs103/portlets/clipper.html

    When I created the portlet I entered the URL http://www.google.com

    My guess would be that your server is located in a place on your network that cannot access the outside? Or maybe it must go through a proxy to hit outside URLs?
  • 655221
    655221 Member Posts: 116
    Maybe an explanation is that browser portlets use an iframe so whether or not that URL can be loaded into the iframe depends on if your browser can hit that URL. In a clipper portlet, which is much more sophisticated, the connection is made from the WLP server. The server can then process the response with things like a custom clipping class before returning it to your browser. Therefore, a clipper portlet's target URL must be accessible from the server.
This discussion has been closed.