Forum Stats

  • 3,851,945 Users
  • 2,264,053 Discussions
  • 7,904,914 Comments

Discussions

Application Deployment works from Admin Console but fails from Workshop?

664622
664622 Member Posts: 1
edited Oct 10, 2008 4:05PM in WebLogic Portal
Hi all,
I am working on a standard Enterprise portal appliication and i am running into a peculiar problem. My application is made of an EAR let's call it my-portal-ear that contains a web app, my-portal-web. I created a Server in Workshop (9.2 like my Weblogic Server version) based on myDomain and added my EAR and it used to deploy and run fine until i decided to change my web app's name in my web.xml and rebuild and redeploy. I made a change to my weblogic.xml as well. I've tried republishing my application through my server view and that's when the trouble started. Ever since then i get either a deployment time out error, or another kind of error but i narrowed it down to the following lines in my server log.

To make a long story short, it seems that instead of calling the
{color:#3366ff}*1223616516281*
*000000 TailEJBCacheFlow starting cache scrubbers for*
app: my-portal-ear
{color:#000000}like in the correct deployment (from the console), Workshop's deployment calls
{color}{color:#3366ff}{color:#000000}{color:#3366ff}*1223613492359*
*000000 destroyServlet: Destroying all servlets named:*
*'wsrp-1.0-ServiceDescriptionPortComponent'*

{color:#000000}All my servlets are destroyed, my Spring session is closed, my beans are destroyed, my ear is removed and deployment fails with the following error:
{color:#ff6600}
java.lang.NoClassDefFoundError: com/bea/p13n/entitlements/management/persistence/internal/PolicyRef
at com.bea.p13n.entitlements.management.persistence.internal.RDBMSEntitlementRef.getResourceElement(RDBMSEntitlementRef.java:456)
at com.bea.p13n.entitlements.management.internal.RDBMSPolicyRefManager.getResourceElement(RDBMSPolicyRefManager.java:258)
at com.bea.p13n.entitlements.management.internal.RDBMSSecurityPolicyManager.getSecurityPolicy(RDBMSSecurityPolicyManager.java:226)
at com.bea.p13n.entitlements.management.SecurityPolicyManager.getSecurityPolicy(SecurityPolicyManager.java:119)
at com.bea.content.manager.internal.ContentUpgradeListener.hasUpgradeBeenDone(ContentUpgradeListener.java:105)
at com.bea.content.manager.internal.ContentUpgradeListener.postStart(ContentUpgradeListener.java:58)
at weblogic.application.internal.flow.BaseLifecycleFlow$PostStartAction.run(BaseLifecycleFlow.java:209)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
at weblogic.application.internal.flow.BaseLifecycleFlow$BaseAction.invoke(BaseLifecycleFlow.java:95)
at weblogic.application.internal.flow.BaseLifecycleFlow.postStart(BaseLifecycleFlow.java:62)
at weblogic.application.internal.flow.TailLifecycleFlow.activate(TailLifecycleFlow.java:33)
at weblogic.application.internal.BaseDeployment$2.next(BaseDeployment.java:635)
at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:26)
at weblogic.application.internal.BaseDeployment.activate(BaseDeployment.java:212)
at weblogic.application.internal.DeploymentStateChecker.activate(DeploymentStateChecker.java:154)
at weblogic.deploy.internal.targetserver.AppContainerInvoker.activate(AppContainerInvoker.java:80)
at weblogic.deploy.internal.targetserver.operations.AbstractOperation.activate(AbstractOperation.java:566)
at weblogic.deploy.internal.targetserver.operations.ActivateOperation.activateDeployment(ActivateOperation.java:136)
at weblogic.deploy.internal.targetserver.operations.ActivateOperation.doCommit(ActivateOperation.java:104)
at weblogic.deploy.internal.targetserver.operations.StartOperation.doCommit(StartOperation.java:131)
at weblogic.deploy.internal.targetserver.operations.AbstractOperation.commit(AbstractOperation.java:320)
at weblogic.deploy.internal.targetserver.DeploymentManager.handleDeploymentCommit(DeploymentManager.java:815)
at weblogic.deploy.internal.targetserver.DeploymentManager.activateDeploymentList(DeploymentManager.java:1222)
at weblogic.deploy.internal.targetserver.DeploymentManager.handleCommit(DeploymentManager.java:433)
at weblogic.deploy.internal.targetserver.DeploymentServiceDispatcher.commit(DeploymentServiceDispatcher.java:161)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer.doCommitCallback(DeploymentReceiverCallbackDeliverer.java:181)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer.access$100(DeploymentReceiverCallbackDeliverer.java:12)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer$2.run(DeploymentReceiverCallbackDeliverer.java:67)
at weblogic.work.ServerWorkManagerImpl$WorkAdapterImpl.run(ServerWorkManagerImpl.java:518)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:181)


{color:#3366ff}{color:#000000}


{color}{color:#3366ff}{color:#000000}Anybody has some insight on why the p13n stuff would work in the console and not in Workshop?
I've tried changing my workspace, deleting and creating a new Workshop server, the only thing i haven't tried yet is deploying on a new domain because setting up the domain for my app is a PITA and i don't want to go through it if i don't have to.

Thanks in advance!
{color}

Edited by: user2977465 on Oct 10, 2008 1:04 PM
This discussion has been closed.