Forum Stats

  • 3,872,248 Users
  • 2,266,410 Discussions


ORA-36836 about cube dimensionality ???



  • chris_here
    chris_here Member Posts: 133
    Hi Stuart,

    what I did lately was this :

    1 - Install Oracle 11G Enterprise Edition v11.1.0.6 from OTN
    2 - Apply patch 6880880 : OPatch v11. upgrade
    3 - Apply patch 6992921 : OLAP B PATCH FOR
    4 - Apply patch 7375639 : Critical Patch Update October 2008 (CPUOct2008)
    5 - Download AWM standalone from OTN

    I get fewer errors with AWM except for the ORA-36836 above, which keeps coming. However I swear I've been able to use my data model at least once, I've even been able to view and play with it in Oracle Answers... However today I tried to restart from scratch (there were just too many test tables etc) and I'm facing this error message again. :-(

    Thanks for your help!
  • Stuart Bunby-Oracle
    Stuart Bunby-Oracle Member Posts: 355
    edited Nov 17, 2008 12:18PM
    So you still haven't tried the [ database patch|] ?

    Whereas I cannot be sure that applying this will fix your problem, I would recommend trying it as I understand that many important fixes were added in this release.

  • chris_here
    chris_here Member Posts: 133
    edited Nov 17, 2008 12:43PM
    A few additional remarks about this crazy thing:

    1) I have been able to create and use a dimension that contains a hierarchy, namely DATETIME.CALENDAR = (ALLDATE, YEAR, MONTH, DAY, HOUR, HALFHOUR). I have a cube T1 with two dimensions, DATETIME and EXITCAUSE and I can play with it as much as I want, no error.

    2) If now I create a cube T2 that contains the hierarchical dimension BNUMBER.BLOCKS = (ALLNUMS, SHORT, CODE, BLOCK) I get the error message, even when I try to view the previous cube T1 above. If I delete T2 I can view T1's data again...

    3) While writing this message I thought this might be due to some reserved keyword in the level names, like SHORT possibly, so I duplicated the dimension using labels like AAA, BBB, CCC, etc. I created a new cube T3 with that dimension and now not only does this new cube T3 work, but T2 and T1 also. I don't have the error message at all anymore. Well this is drivin me totally nuts.

    At least it seems I have a workaround, just create a few random cubes with random element names and eventually the bug seems to go away. But still this is incredebly annoying. I really whish I could reach one of the AWM developpers to get this known at least.

    I'm willing to provide any test case if anyone is interested, only I won't be able to fill an SR I guess.


    PS: I'll try the patch you indicate and keep you posted. Regards. Chris
  • I think we have all experienced unexplained errors in the past and can associate with your frustration.

    I will make sure that someone from development takes a look at this thread but the only way you can guarantee a formal response would be to capture your experiences on Metalink in an SR (if your Oracle Support access code does not work then call Oracle and find out why)

    Let me know how you get on with the database patch - irrespective of this particular issue, you really should be using this anyway


  • Hi there, I work in OLAP Dev. Please can you upgrade to to try it with AWM And/or do you get this error when you use with appropriate patches and AWM 11.1.06A?

    Please turn sql trace on at the database level, execute your operation, detach from AWM and send me the resulting sql trace. Do this with one of the above combinations of AWM/db ( is best) and send me the sql trace while you sort out your CSI number.. I can progress the issue while a SR is being opened.

    My email is [email protected]

    Thanks, Laura
  • David Greenfield-Oracle
    David Greenfield-Oracle Member Posts: 877 Employee
    Quite by accident we have just stumbled across this same problem in development against an instance. As in the reported case, changing the name of a level (in this case from VALUE to CUSTOMER_VALUE) made the cube viewer work again. I hope we will be able to track this down in house and explain what is happening.
  • chris_here
    chris_here Member Posts: 133
    Hi there again,

    I've just upgraded to and I still get the same error message. However it is clear now that the issue is due to a conflict between level names and some reserved words, since the error doesn't appear when I use meaningless identifiers instead of 'CODE', 'BLOCK' and 'SHORT'. So the issue is not really serious, at least if it's known !

    I've send some trace files to Laura so hopefully the issue will be identified more precisely soon.

    Anyway the big relief now is that the problem has nothing to do with cube dimensionality because that was making me feel real bad :-)

    Thanks to all for your support,
  • 438862
    438862 Member Posts: 11

    There's a bug in the a parser which is exposed when using the Data Viewer. Not to bore you with the details, but this layer of code is going throw an old code path that uses a parser that is sensitive to certain keyword names (base, short, long, integer, dimension, etc...). To work around the issue add a simple prefix or postfix to cube, dimension and hierarchy names. For example, instead of a dimension PRODUCT, hierarchy BASE and cube SALES create a dimension PRODUCT_DIM and a hierarchy BASE_HIER and a cube SALES_CUBE. It's a bit of a pain but you won't hit the issue anymore.

    A bug will be created and the issue will be resolved in a future release.

  • chris_here
    chris_here Member Posts: 133
    Hi Christopher,

    thanks a lot for this information. I think it's good to have this information on the thread, as now if someone stumbles on the same issue they'll be able to google it and immediately get the answer.

This discussion has been closed.