Forum Stats

  • 3,782,584 Users
  • 2,254,669 Discussions
  • 7,880,131 Comments

Discussions

unable to register OrderbookingESB - SOA demo application

676091
676091 Member Posts: 11
edited Feb 9, 2009 5:20AM in SOA Suite Discusssions
Hello gurus,

I am running SOA suite 10.1.3.1.0 and have been able to setup the rest of the demo application. When i try to register the OrderBookingESB application I get the following error -

Entity Deployment Failed

error code: 1049 : 5
summary: WSDL "http://localhost:8888/orabpel/default/SOAOrderBooking/1.0/SOAOrderBooking?wsdl" of service "OrderBooking.OrderBookingProcess" is invalid or unaccessible. Following error is thrown by WSDL Parser : WSDL Parsing Failed: http://localhost:8888/orabpel/default/SOAOrderBooking/1.0/SOAOrderBooking?wsdl
Fix: Ensure that the WSDL is accessible and valid. If the problem persists, Contact Oracle Support.


Do i need to install a patch? I am not a member of metalink (I am a freelancer) - can I still download the patchset?

Also a question about versions of SOA suite (sorry I am only starting off with SOA suite) - why is it that the latest download of SOA suite does not have all the patches preinstalled?

Many thanks,
DS
Tagged:

Answers

  • You don't need to install a patch but I would suggest upgrading to 10.1.3.4. This is available on OTN.

    http://www.oracle.com/technology/software/products/ias/htdocs/101310.html

    The issue it looks like you are facing is that you are deploying in an incorrect order. You need to deploy the bpel process first 'SOAOrderBooking'. The esb that you are trying to ndeploy is trying to connect to this wsdl and it doesn't exist.

    to check manually go to the following url

    http://localhost:8888/orabpel/default/SOAOrderBooking/1.0/SOAOrderBooking?wsdl

    cheers
    James
  • 676091
    676091 Member Posts: 11
    Hi James, yes you were right - i got the order wrong but that being said I was correctly following the order mentioned in the Oracle SOA orderbooking tutorial - which i must say needs a makeover!

    Also if I upgrade SOA suite to 10.1.3.4 will I also need to upgrade the Jdeveloper version?

    Cheers
    DS
  • Yes your JDev version should always match your SOA Suite.

    cheers
    James
  • 683959
    683959 Member Posts: 1
    Hi All,

    Even i am facing the same issue.

    I am getting:

    error code: 1049 : 5
    summary: WSDL "http://www.dataaccess.com/webservicesserver/numberconversion.wso?WSDL" of service "Scenario4B.myNum2WrdSoap"
    is invalid or unaccessible. Following error is thrown by WSDL Parser : WSDL Parsing Failed: No route to host
    Fix: Ensure that the WSDL is accessible and valid. If the problem persists, Contact Oracle Support.

    I have followed the same sequence.

    Can someone look into this and help me out?
This discussion has been closed.