Forum Stats

  • 3,781,633 Users
  • 2,254,532 Discussions
  • 7,879,770 Comments

Discussions

SAMLCredentialMapper - Clustered Env

681696
681696 Member Posts: 51
edited Aug 10, 2009 12:57PM in WebLogic Portal
Hi

I am getting the following error while starting my 2nd Manged server in the cluster(has 2 mged servers)

####<Aug 10, 2009 10:48:26 AM EEST> <Error> <Security> <saerporq15> <wl-rp-rportal-2> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1249890506575> <BEA-090854> <SAMLCredentialMapper provider initialization failed: Could not retrieve credentials for AssertionSigningKey.>


Whn I checked the weblogic documentation it says "Check SSL configuration" , I am not sure what needs to be configured ?

BEA-090854 Error: provider provider initialization failed: Could not retrieve credentials for alias.
Description The provider provider requires PKI credentials associated with the alias alias, which could not be retrieved by the SAMLKeyManager.
Cause SSL identity not configured for server.
Action Check SSL configuration.

help required ...

Thanks in Advance
rajesh
Tagged:

Answers

  • 672451
    672451 Member Posts: 1,016
    are you getting this on both managed servers or just on one? If just on one then your keystore files arent present on all managed servers.
    It looks like you havent configured the Certificates (under SAMLIdentityAsserter --> management --> certificates ) , if thats correct check your keystore configuration for your managed server
    regards
    deepak
    672451
This discussion has been closed.