Forum Stats

  • 3,851,489 Users
  • 2,263,988 Discussions
  • 7,904,739 Comments

Discussions

Problem in refreshing the data in OBIEE answers?

kart
kart Member Posts: 804
Hi,

My report doesn't show the latest data in the database. I tried restarting my BI server and Presentation server also. But it is still showing the old data only. But in Admin tool im able to view the latest data. What could be the reason for this? Wont the refresh button given at the bottom of the report refresh the data?

Thanks,
Karthick
Tagged:

Best Answer

  • Goran Ocko
    Goran Ocko Member Posts: 554
    Answer ✓
    Are you using cache and did you enable/disable it in the NQSConfig.ini?

    See if the table is cacheable (table properties) in the physical layer, you can turn on/off it per table.

    Regards
    Goran
    http://108obiee.blogspot.com

Answers

  • Goran Ocko
    Goran Ocko Member Posts: 554
    Answer ✓
    Are you using cache and did you enable/disable it in the NQSConfig.ini?

    See if the table is cacheable (table properties) in the physical layer, you can turn on/off it per table.

    Regards
    Goran
    http://108obiee.blogspot.com
  • kart
    kart Member Posts: 804
    Hi Goron,

    Thanks for your reply.. in table properties everything is set as Cacheable only.. In .ini file also Cache is set to TRUE only. Do i need to modify this?

    Thanks,
    Karthick
  • Goran Ocko
    Goran Ocko Member Posts: 554
    edited Sep 7, 2009 10:18AM
    :-)

    If you are not using cache, then yes, modify it.

    Regards
    Goran
    http://108obiee.blogspot.com
  • kart
    kart Member Posts: 804
    Hi Goran,

    Sorry for that..:) I'll do it and let you know..

    Thanks,
    karthick
  • mod100
    mod100 Member Posts: 282
    Hi,

    If you want to use the cache and you have a regular load of data into your source for OBIEE, then you just need to ensure that the cache is cleared after your load. There is an ODBC command which will clear it:

    Call SAPurgeAllCache();

    You can put this in a sql file and then call it from a .cmd file:

    nqcmd -d "AnalyticsWeb" -u Administrator -p <password> -s D:\OracleBI\server\Scripts\Common\purge_cache.sql -o D:\OracleBI\server\Scripts\Common\purge_cache.out

    When you run this .cmd file it will clear the cache, this could then be caled from another tool, i.e. an Informatica workflow. All above is based on using a windows machine to connect and run the command.

    If your data is changing all the time and you just don't want caching on then just turn it off in nqsconfig.ini, change:

    ENABLE = YES;

    To

    ENABLE = No;

    in the cache section.

    Regards,

    Matt
    mod100
  • 683117
    683117 Member Posts: 24
    Hi karthick,
    i faced same issue for a specific report and reason is the cache is enanbled.
    sol:
    depending on cache* need to your reports.
    *Cache improves performance but increases latency in accuracy of reports. see this blog post to understand about cache (http://obiee101.blogspot.com/2008/07/obiee-cache-management.html)

    Either
    simply turn off cache in NQSconfig.ini file.so that you will always get latest results.

    Or
    Set the frequency of cache clearance** equal to your source data change interval.

    **you can use above said cmd script for cache purging.

    hope that helps

    -Niranjan
  • kart
    kart Member Posts: 804
    Hi Team.. Thanks for your support.. It worked


    Regards,
    Karthick
This discussion has been closed.