Forum Stats

  • 3,872,071 Users
  • 2,266,376 Discussions
  • 7,911,043 Comments

Discussions

Green bar styling not applied to all columns

Hi,

I'm trying to improve the appearance of my dashboards in OBIEE.
I'm using a coumpond view with a table or a pivot table –problem happens in both cases.

Sometimes, for some tables, the first column dont get alternate row styling.

For example I have a table looking like this:
| Date | Col1 | Col2 | Col3 |

The last 3 columns will have alternate styling but the first one doesnt get it. The CSS class generated for every row is PTROW2. While the classes for the other colums are PTROW1 alternated with CustomCell, which I created into custom.css

Any idea why OBIEE wouldn't generate alternate class names for some columns?

Thanks

Best Answer

  • 723150
    723150 Member Posts: 29
    Answer ✓
    Sounds like you are using custom css classes. Does this issue exist if you do not customize anything?
    Also, you may have already done this, in pivot table, where you Enable alternating Green Bar styling, there is an option to select "Innermost Column" and "All Columns". It should be set to All Columns.

Answers

  • 694975
    694975 Member Posts: 36
    Can you check the background color for that particular column. There should be no value set for the color in the properties window
  • 717256
    717256 Member Posts: 50
    There is nothing.
    To make sure of that I went to Dashboard > Edit dashboard > on the table, Modify request > Click column property > Click the rubber to get rid of all the formatting > Save as system wide setting > Save report.

    Should I do it somewhere else?
  • 717256
    717256 Member Posts: 50
    Anyone already had this issue?
  • David_T
    David_T Member Posts: 2,432
    Do you have any other customized formatting on column one? If so, this will override the "alternating green row" effect.

    As a test (assuming you don't know), did you switch out the order of columns to determine whether it is column one or the first column? Does it happen with all reports or just this one?
  • 717256
    717256 Member Posts: 50
    Ok so I checked, and after further investigation, here are my conclusions:

    Only the FIRST column of the pivot table gets affected. If I switch the colum order, the one on the left will always NOT get the alternate formatting while the other ones will.
    So it doesnt seems like its related to a specific column.

    I also tried creating a report from scratch, and when I mix certain columns (example Dates with something called Publisher) then the first colum of the pivot table gets affected and looses its alternate row formatting.

    Does anyone know about this issue?
  • 723150
    723150 Member Posts: 29
    Answer ✓
    Sounds like you are using custom css classes. Does this issue exist if you do not customize anything?
    Also, you may have already done this, in pivot table, where you Enable alternating Green Bar styling, there is an option to select "Innermost Column" and "All Columns". It should be set to All Columns.
  • 694975
    694975 Member Posts: 36
    Hi,

    Here is a possible work around.
    Duplicate the first column.
    In the first column..enter in custom css display:none for both the header and the column
    694975
  • 717256
    717256 Member Posts: 50
    I though so too, but all column is already selected.
  • 687696
    687696 Member Posts: 186
    I am also facing this problem.... is it a bug?
This discussion has been closed.