Forum Stats

  • 3,872,827 Users
  • 2,266,483 Discussions


EPM SQL Server 2008 Problem

gurkanonay Member Posts: 23
edited Jan 30, 2012 9:21AM in EPM System Infrastructure
i am trying to configure shared service on SQL Server 2008, i am getting a error as below.This table is in database as named "SMA_AUDIT_AREA_DIM", which collation must i use for database, i used TURKISH_CI_AS.

java.sql.SQLSyntaxErrorException: [FMWGEN][SQLServer JDBC Driver][SQLServer]Invalid object name 'sma_audit_area_dim'.


I replaced i to I in the sqlserver_cms.sql script before configure shared service, it worked fine, but shared service doesn't start giving error as below.

EPM System Security is not initialized properly.



  • JohnGoodwin
    JohnGoodwin Member Posts: 30,471 Blue Diamond
    Have a read of -


  • gurkanonay
    gurkanonay Member Posts: 23

    i found it but there isn't information about sql server database collation in epm_install_start_here.pdf document.

    i am still getting same error as below.

    Error: EPM System Security is not initialized properly

    i installed this version several time on oracle database but now i have trouble with sql server, i am using windows server 2008 R2 x64,

    before start to installation&configuration,i changed these settings on machine.

    - redefine user temp/tmp directory variables as C:\Temp and C:\Tmp
    - disable Delete temporary folders on exit option.
  • Can you post the exact error message that is written in the foundation0.log file?
  • John A Booth
    John A Booth Member Posts: 1,508
    John G provided you a direct link to the page in the Start Here Guide with the collation which needs to be set to: SQL_Latin1_General_CP1_CI_AS for all of your databases as well as the READ_COMMITTED_SNAPSHOT and ALLOW_SNAPSHOT_ISOLATION.

    I suggest you delete and recreate all of your databases and ensure the proper collation and options are setup and then proceed. You should not need to edit any .sql files in order to configure.

    Good Luck,

    John A. Booth
  • gurkanonay
    gurkanonay Member Posts: 23
    Hello John,

    i used database settings as Jhon G provided me, but i understood that my problem was not related to database setting.

    Regional settings of server are english but there is cp1254 in foundationservices0.log , i changed file.encoding properties to cp1252 , then problem is solved, i could not understand how happened this situation.

    Thanks everybody.
This discussion has been closed.