Forum Stats

  • 3,876,133 Users
  • 2,267,067 Discussions


Cannot Create folders in Discoverer- ORA- 02289 Sequence Does Not Exist

AI Consulting
AI Consulting Member Posts: 6
edited Nov 13, 2012 10:27AM in Discoverer
After installing Discoverer (Version on several new machines, we are not able to create a view. We have installed on 6 different machines and all have the same problem: The window gets to the screen where you validate the SQL and submit your new folder, but the new folder does not show up.

The Payment Administrator responsibility does not have the Create Folders Privledge, neither did the System Administrator Responsibility. However, the username that we have been using 'SYSADMIN' DOES have the Create Folder privledge. I logged in as the EUL origional username and changed the privledges for the responsibility: System Administrator. After this, ,I get the same error, and I am still unable to create a folder, AND, I was unable to log into production (a new symptom). In order to enable us to log back into production I had to change the privledges back to what they were before.

The same user/ responsibility works with a different computer, so Discoverer has already been integrated with E-Business Suite correctly. The machine it is working on is also a 64 bit machine and the user/ responsibility is also the same. I have tried re-installing in compatability mode and I get the same error. I also tried to install on my virtual PC but I am getting a different error that has to do with a missing .dll file.

Nothing was changed, it still works on the machine it worked on before, but new installs do not work.


I was able to get passed the error I was getting about the missing library file on my virtual PC, however, now I get the same error I have been getting on my Windows 7 64 bit "ORA - Sequence does not exist".

So now the error is on both my wondows 7 OS (64 bit), AND on my Windows XP mode 32 bit virtual PC.

Edited by: joe_artley on Oct 17, 2012 2:07 PM


  • Rod West
    Rod West Member Posts: 4,025 Gold Trophy

    The sequence does not exist problem could just be a problem with the privileges at the database level especially you see this error when you try to create any object in the EUL.

    To make sure you have the correct privileges at the database level, login at the eul owner using sqlplus and enter this grant:

    grant all on eul5_id_seq to apps;

    Rod West
  • AI Consulting
    AI Consulting Member Posts: 6
    edited Oct 18, 2012 10:22AM
    Thank you for the quick reply. I tried and still get the same error.

    Another update: I get the error when I try to query from Discoverer Desktop if I try to query as soon as I open a workbook BUT not if I choose not to query when I open the workbook and instead hit refresh after it opens. So now the error is in Desktop AND Administrator.

    A colleague installed Discoverer on her computer 6 months ago and can create and modify tables on her laptop. The only thing that may have changed is a change in servers at the client site. I would think this would be taken into account already but I cannot think of anything else that is different between the two installations. The DBC files are only for the DEV instance and the error happens in prod and TST. The installs are both

    Any suggestions?

    Edited by: joe_artley on Oct 18, 2012 7:01 AM
  • Rod West
    Rod West Member Posts: 4,025 Gold Trophy

    You could try running a database trace on the session where this error occurs which should show you exactly why you get this error.

    Rod West
    Rod West
  • Thank you for your help, I will do that the next time I have an error. It turns out the problem was the End User Layer (EUL) was not selected as the default. So when you first install Discoverer, the EUL that you will be using needs to be selected. This was giving the permission-like errors.

    Thank you for your help.
This discussion has been closed.