Forum Stats

  • 3,839,596 Users
  • 2,262,511 Discussions


Getting Error Unable to retrieve folder information. Permission denied.

Nikhil Raut
Nikhil Raut Member Posts: 12
edited Jan 10, 2013 4:10AM in WebCenter Portal

I'm getting below error stack whenevr i'm trying to connect my application to remotally to the content server.
for that i'm using adaptorConfig.xml file.

below is the error stack :-

Exception fetching content
com.stellent.cis.client.command.CommandException: Unable to retrieve folder information. Permission denied. Address 'XX.XX.XXX.XX' is not an allowable remote socket address.
at com.stellent.cis.server.api.scs.impl.SCSCommand.executeRequest(
at com.stellent.cis.server.api.scs.impl.SCSCommand.execute(
at com.stellent.cis.client.command.impl.CommandFacade.executeCommand(
at com.stellent.cis.client.command.impl.BaseCommandAPI.invokeCommand(
at com.stellent.cis.client.api.scs.component.folder.impl.SCSComponentFolderAPI.getFolder(
at com.guycarp.portlets.html.FeatureBoxArticleBean.init(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at com.sun.el.parser.AstValue.invoke(Unknown Source)
at com.sun.el.MethodExpressionImpl.invoke(Unknown Source)
at oracle.adf.controller.internal.util.ELInterfaceImpl.invokeMethod(
at oracle.adfinternal.controller.activity.MethodCallActivityLogic.execute(
at oracle.adfinternal.controller.engine.ControlFlowEngine.executeActivity(
at oracle.adfinternal.controller.engine.ControlFlowEngine.doRouting(
at oracle.adfinternal.controller.engine.ControlFlowEngine.doRouting(
at oracle.adfinternal.controller.engine.ControlFlowEngine.invokeTaskFlow(
at oracle.adfinternal.controller.state.ChildViewPortContextImpl.invokeTaskFlow(
at oracle.adfinternal.controller.state.ControllerState.createChildViewPort(
at oracle.adfinternal.controller.ControllerContextImpl.createChildViewPort(
at oracle.adf.controller.internal.binding.DCTaskFlowBinding.createRegionViewPortContext(
at oracle.adf.controller.internal.binding.DCTaskFlowBinding.getViewPort(
at oracle.adf.controller.internal.binding.TaskFlowRegionModel.doProcessBeginRegion(
at oracle.adf.controller.internal.binding.TaskFlowRegionModel.processBeginRegion(

Even i opened the port of the content server for my IP address but still i'm getting same error.

i have tryied same configuration form another laptop its working it's really deficult to find me out what is the exact problem for my Laptop

Thanks you very much ... eagerly waiting for your valuable reply


  • Kishore Rout
    Kishore Rout Member Posts: 95
    Update the config.cfg file(SocketHostAddressSecurityFilter=XXX.XXX.XX.XXX) present in $domain_home/ucm/cs/config. XXX.XXX.XX.XXX is the ip address displaying in your error log file.

  • Thanks a lot Mate !

    Kishor , i have done this activity befor ...even dev UCM server is restarted ...but i'm still getting same error ...

    any other solution / clue for same issue ???
  • Jiri.Machotka-Oracle
    Jiri.Machotka-Oracle Member Posts: 5,078
    edited Jan 10, 2013 4:10AM
    In my system the parameter is setup as|0:0:0:0:0:0:0:1|*.* .* .* (it does not display correctly - do not copy!, but it is asterisk - dot - asterisk - dot - asterisk - dot - asterisk)

    (you will need to restart the server when you change it to make it effective)

    Edited by: jiri.machotka on Jan 10, 2013 10:07 AM
This discussion has been closed.