Forum Stats

  • 3,875,555 Users
  • 2,266,945 Discussions
  • 7,912,249 Comments

Discussions

Where can I find the latest version of agent for linux for download?

Johand -Oracle
Johand -Oracle Member Posts: 5 Employee
edited Sep 23, 2014 4:21PM in Enterprise Manager Ops Center

I have trouble when I try to install an agent in Linux for opscenter, I get this message:  status bad  interpreter, I check manually the script and I found that many internal scripts are written for Solaris in the last version release 2 PSU1. Can everybody help me?

Answers

  • Michele Vecchiato
    Michele Vecchiato Member Posts: 30
    edited Aug 26, 2014 5:46PM

    Hi JohAnd,

    I imagine have you tried "./OCDoctor.sh --agent-prereq" command?  What's the output?

    You can download Oracle Enterprise Manager Ops Center installation bundles from the Oracle Technology Network or from e-Delivery.For obtaining the software read here.

    HTH

    Michele V.

    P.S.: OCDoctor download here http://java.net/projects/oc-doctor/downloads and click the OCDoctor-LATEST.zip download.

    --

    If you want, mark the reply as “Helpful Answer“ or “Correct Answer”. By marking replies correct or helpful, you make it easier for community members to find replies that might help them in a similar situation"

  • Johand -Oracle
    Johand -Oracle Member Posts: 5 Employee

    Hi Michele V,

    Yes I  run the OCDoctor and output was:

    ./OCDoctor.sh --agent-prereq

    Ops Center Doctor 4.33  [Linux]

    ========== Checking 12c Agent Controller Requirements ... ====================

    ERROR: gettext is not installed.

    ./prereq/agent_prereq_all.sh: line 57: gettext: command not found

    ./prereq/agent_prereq_all.sh: line 57: gettext: command not found

    ./prereq/agent_prereq_all.sh: line 57: gettext: command not found

    ./prereq/agent_prereq_all.sh: line 57: gettext: command not found

    ERROR: 32-bit version of libxml2 is not installed.

    ./prereq/agent_prereq_all.sh: line 57: gettext: command not found

    ./prereq/agent_prereq_all.sh: line 57: gettext: command not found

    ./prereq/agent_prereq_all.sh: line 57: gettext: command not found

    ./prereq/agent_prereq_all.sh: line 57: gettext: command not found

    OK: Servicetag is not installed (sun-servicetag)

    OK: No old agent / conflicting packages were found

    OK: No old agent processes are running

    OK: LD_LIBRARY_PATH is not set

    OK: Checked for ssh requirements

    ./prereq/agent_prereq_all.sh: line 57: gettext: command not found

    You have mail in /var/spool/mail/root

    -----------------------------------------------------------------------------------------------------------------------------------------------

    I appreciate yoiuyr help

  • Hi JoaHan,

      Missing packages "gettext" and "libxml2". Please try to install (run "yum install gettext libxml2" for CentOS or RHEL distributions) and re-executed "./OCDoctor.sh --agent-prereq". If all are OK try to install Ops Center Linux agent.

    ERROR: gettext is not installed.
    ./prereq/agent_prereq_all.sh: line 57: gettext: command not found
    ...
    ERROR: 32-bit version of libxml2 is not installed.
    

    HTH

    Michele V.

    --

    If you want, mark the reply as “Helpful Answer“ or “Correct Answer”. By marking replies correct or helpful, you make it easier for community members to find replies that might help them in a similar situation"

  • Johand -Oracle
    Johand -Oracle Member Posts: 5 Employee

    Thanks everybody for your answers, but in this case the customer can't install that packages for the version of their aplication's.

This discussion has been closed.